Closed Bug 525316 Opened 12 years ago Closed 8 years ago

Create notification system for large changes in crash report trends

Categories

(Socorro :: General, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: morgamic, Unassigned)

References

Details

(Whiteboard: Q3 [explosive])

We need something that sends email or alerts to a list of people if the frequency of a particular crash signature increases by a specified amount (to be determined).  This is similar to the notifications they have in place for when the tree breaks for Firefox dev.  Damon can give more info.

My suggestion for a delta to watch is an increase in crash frequency of more than 50-75% and new crashes in the top 20 overall signatures by version.
Ryan - this is related to the top movers bug you're working on with Chris.  May be a dupe.  What's the scope of your work regarding alerts?
Assignee: nobody → ryan
Target Milestone: 0.6 → 1.7
Not a problem.  But need to push this out to 1.8.
Target Milestone: 1.7 → 1.8
Everybody wants this in the 2.0 interviews.  The desired outcome is a newsgroup posting.  If you can build something for 1.8 I'm all for it, otherwise 2.x is fine.
Target Milestone: 1.8 → 1.9
Assignee: ryan → nobody
Duplicate of this bug: 629075
Blocks: 629049
Whiteboard: Q3 [explosive]
Target Milestone: 1.9 → ---
Component: Socorro → General
Product: Webtools → Socorro
Depends on: 629062
Duplicate of this bug: 735933
Duplicate of this bug: 765083
I don't know if people still want emails, but in general, this is covered now by a combination of Shu Hao's explosive crash anomaly detection and Kairo's explosive report.

[1] https://crash-stats.mozilla.com/explosive/
[2] e.g. https://crash-analysis.mozilla.com/rkaiser/2014-03-25/2014-03-25.firefox.31.explosiveness.html

Resolving for now. Please reopen if you want alerting.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Bumping to verified as [qa-].
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.