Make user-agent string more sensitive to privacy

RESOLVED DUPLICATE of bug 55366

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 55366
8 years ago
8 years ago

People

(Reporter: messi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

Currently, the User-Agent string contains Gecko's version, Firefox's version and a build id which is based on a timestamp. People who do not use official builds have different and sometimes unique build ids and because most webservers log the user-agent these users can be tracked even without cookies.

While my above mentioned Build Identifier would suggest that I use Vista, I certainly do not, I use Ubuntu with my own optimized build of Firefox. I changed the user-agent string via extension to hide in the crowd. My build id which is even different from Ubuntu's would make me really stand out.

I beg, yes beg, Mozilla for a much more privacy-respecting user-agent string. Information about the build can still be collected via Javascript if neccessary and if allowed by Firefox.

Current UA:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729) Blah/1.2 Blah/2.3 Blah/3.4

Compromise:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; official) Gecko/1.9.1.4 Firefox/3.5.4

My proposal:
Mozilla/5.0 (official; rv:1.9.1) Gecko/1.9.1 Firefox/3.5

Future UA?
Firefox/3.5 (official; Gecko 1.9.1)

My problem is mostly with third-party elements on websites such as ads and scripts that are loaded from Google, Doubleclick, et al. but there is no reason why normal websites should automatically collect this information either.

Please think about it. Privacy is where Firefox can make a difference.


Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 55366

Comment 2

8 years ago
See bug 71569 (meta-bug UA string) and bug 57555 (don't show system software incl. versions)
You need to log in before you can comment on or make changes to this bug.