The default bug view has changed. See this FAQ.

Add support for Firebug

VERIFIED FIXED in seamonkey2.1a1

Status

SeaMonkey
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

({fixed-seamonkey2.0.1})

Trunk
seamonkey2.1a1
fixed-seamonkey2.0.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [firebug-p3], URL)

Attachments

(2 attachments)

(Assignee)

Description

8 years ago
Created attachment 409509 [details] [diff] [review]
add isTargetAFormControl [Checkin: comment 2]

I think many people (including me, obviously) would like to have a SM2-compatible Firebug. I created this bug to track the changes on both sides, i.e. Firebug and SeaMonkey. Since this is one of the most important extensions for web developers I'd like to have it rather sooner than later, i.e. we should try to have this ready for SM 2.0.1 (or .2, ...) and not wait for SM 2.1.

For initial support, adding an overlay line is enough (see URL on this bug; I used Firebug 1.5X.0b1). Adding menuitems to View and Tools is also quite easy, I'll attach a patch for that shortly. Once those three have been addressed, most things already work. One notable exception is the context menu which is broken. I found this on the Error Console:

Error: this.isTargetAFormControl is not a function
Source file: chrome://firebug/content/editorToContextMenu.js
Line: 34

This tries to access an nsContextMenu member function which is not available in SM yet. I'd like to add it for SM 2.0.1 to achieve Firebug support without them having to add duplicate code just to support us (actually, if I were them, I'd reject any such suggestion, too). If someone feels that we should make use of that new function ourselves I suggest to move that discussion to another bug; a lengthy discussion here will only push back the availability of Firebug for SeaMonkey.
Attachment #409509 - Flags: superreview?(neil)
Attachment #409509 - Flags: review?(neil)
Attachment #409509 - Flags: approval-seamonkey2.0?
(Assignee)

Comment 1

8 years ago
Created attachment 409510 [details] [diff] [review]
add SM overlays
Attachment #409510 - Flags: review?(johnjbarton)

Updated

8 years ago
Attachment #409509 - Flags: superreview?(neil)
Attachment #409509 - Flags: superreview+
Attachment #409509 - Flags: review?(neil)
Attachment #409509 - Flags: review+

Updated

8 years ago
Attachment #409509 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+

Updated

8 years ago
Attachment #409509 - Flags: approval-seamonkey2.0+ → approval-seamonkey2.0.1+
(Assignee)

Comment 2

8 years ago
Comment on attachment 409509 [details] [diff] [review]
add isTargetAFormControl [Checkin: comment 2]

http://hg.mozilla.org/comm-central/rev/c4c7a41a059c

http://hg.mozilla.org/releases/comm-1.9.1/rev/96c126b0b755
Attachment #409509 - Attachment description: add isTargetAFormControl → add isTargetAFormControl [Checkin: comment 2]
(In reply to comment #0)
> I think many people (including me, obviously) would like to have a
> SM2-compatible Firebug.

Ftr, at EU MozCamp 2009 (Prague), I talked with the one (= Honza !?) who did the Firebug session, about looking forward to this ... and slowly starting to wonder if/when SM should package Firebug/ChromeBug instead of Venkman ;-)
Though I have not yet used either of the latters.
Version: Other Branch → Trunk
(In reply to comment #3)

Hum: "the latters" == FB+CB.

Comment 5

8 years ago
Chromebug requires Firebug, so getting Firebug to work is a great first step. We have new support for anonymous elements in Gecko, so Chromebug should be able to deal with XBL soon. Then there are only two significant issues: Chromebug uses some 'browser' UI files not present in other platforms and it is probably missing a few features (though it also has many you don't get in DOMi + venkman).
adding a firebug tag to the whiteboard so this shows up in triage.
Whiteboard: [firebug-p3]

Comment 7

8 years ago
adding fixed-seamonkey2.0.1 keyword to not show up in the "approved but not checked in" query for 2.0.1
Keywords: fixed-seamonkey2.0.1
(Assignee)

Updated

8 years ago
Attachment #409510 - Flags: review?(johnjbarton)
(Assignee)

Comment 8

8 years ago
Comment on attachment 409510 [details] [diff] [review]
add SM overlays

The changes from the Firebug patch have been applied upstream (see URL on this bug).
(Assignee)

Comment 9

8 years ago
Marking fixed. Thanks John! Someone (other than me, probably) should mark it VERIFIED once a Firebug version with the changes is released. Please keep in mind that a recent SM 2.0.1pre nightly is needed for a successful test.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a1
(Assignee)

Comment 10

8 years ago
Fixed in stock Firebug 1.5.0b4, marking VERIFIED (using current 2.0.1pre nightly).

Note: Filed http://code.google.com/p/fbug/issues/detail?id=2498 for the non-working Open Firebug in New Window.
Status: RESOLVED → VERIFIED

Comment 11

7 years ago
Have installed this nightly build of Seamonkey on my Laptop here
It is the newest at the moment and it works great on my Laptop
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-1.9.1/seamonkey-2.0.1pre.en-US.linux-i686.tar.bz2

Have tryed to install and run the Firebug version that was confirmed to work
with Seamonkey 2.0.1 from here.
For some reason Seamonkey fails to install and run the extension that worked before in Seamonkey.
http://getfirebug.com/releases/firebug/1.5X/firebug-1.5X.0b4.xpi


Please fix this Bug if possible!

Updated

7 years ago
Flags: wanted-seamonkey2.1?
This bug is marked as fixed. Please fill new bug if you think that something is wrong.
(Assignee)

Comment 13

7 years ago
Removed wanted‑seamonkey2.1 flag request since the SM part (which was only for proper context menu support anyway) has already landed. Whatever needs to be done in addition (e.g. see comment 10) will either be completely on the Firebug side or, in case an SM change is needed, requires a new bug.

@aran: Just tried with a current SM 2.0.1pre nightly in a Kubuntu 8.04.1 (Linux) VM, a fresh profile and the Firebug link you provided. Worked like a charm. If it really doesn't work for you you need to at least be more specific (error message? What does the Add-on Manager show? Tried with a fresh profile?).
Flags: wanted-seamonkey2.1?

Comment 14

7 years ago
Jens Hatlak !

You are great !
Thanks a lot for veryfication that for you it worked !

Just after reading your comment i have reinstalled everything and for my surprise Firebug works now in Seamonkey.
It must be some profile problem maybe also with the older version of Seamonkey 1.8.

You cant imagine how much i have missed this plugin in Seamonkey.

Really Great Work People !
You need to log in before you can comment on or make changes to this bug.