Last Comment Bug 525710 - getPagesWithAnnotation, getItemsWithAnnotation, getPageAnnotationNames, getItemAnnotationNames, getFaviconData, getQueries, getFolders and getTagsForURI length out params should be optional
: getPagesWithAnnotation, getItemsWithAnnotation, getPageAnnotationNames, getIt...
Status: RESOLVED FIXED
: dev-doc-complete
Product: Toolkit
Classification: Components
Component: Places (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.3a1
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on: 523817
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-01 01:03 PDT by Dão Gottwald [:dao]
Modified: 2010-11-09 07:19 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (94.61 KB, patch)
2009-11-01 01:03 PDT, Dão Gottwald [:dao]
sdwilsh: review+
Details | Diff | Review

Description Dão Gottwald [:dao] 2009-11-01 01:03:39 PDT
Created attachment 409573 [details] [diff] [review]
patch
Comment 1 Shawn Wilsher :sdwilsh 2009-11-02 12:36:01 PST
Comment on attachment 409573 [details] [diff] [review]
patch

r=sdwilsh for the pure awesomeness of this patch.  We should take this on 1.9.2 too so folks can start using the simpler API calls sooner.
Comment 2 Dão Gottwald [:dao] 2009-11-02 13:14:25 PST
http://hg.mozilla.org/mozilla-central/rev/6d7d38a57ed2
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-12-01 17:32:46 PST
Comment on attachment 409573 [details] [diff] [review]
patch

approval1.9.2 requests aren't currently being monitored, since we're nearing RC freeze and there are too many outstanding requests, so I'm clearing this request. Feel free to re-request approval if you are confident that it's worth drivers' time to consider whether this non-blocker needs to land for 1.9.2 at this stage.
Comment 4 Eric Shepherd [:sheppy] 2010-11-09 07:19:14 PST
Documentation updated. Also found and fixed a few errors in the docs while I was at it.

Note You need to log in before you can comment on or make changes to this bug.