If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

xulrunner -help crashes [@ LoadPlatformDirectory]

RESOLVED FIXED

Status

()

Toolkit
Startup and Profile System
--
critical
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(status1.9.2 beta3-fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Access violation - code c0000005
  nsresult rv = aBundleDirectory->Clone(getter_AddRefs(platformDir));
aBundleDirectory is null.

Call stack:
xul!LoadPlatformDirectory
xul!nsXREDirProvider::LoadBundleDirectories
xul!nsXREDirProvider::GetFilesInternal
xul!nsXREDirProvider::GetFiles
xpcom_core!FindProviderFile
xpcom_core!nsSupportsArray::EnumerateBackwards
xpcom_core!nsDirectoryService::Get
xpcom_core!AppendFromDirServiceList
xpcom_core!xptiInterfaceInfoManager::BuildFileSearchPath
xpcom_core!xptiInterfaceInfoManager::GetInterfaceInfoManagerNoAddRef
xpcom_core!NS_InitXPCOM3_P
xul!ScopedXPCOMStartup::Initialize
xul!DumpArbitraryHelp
xul!DumpHelp
xul!XRE_main
seamonkey!NS_internal_main
seamonkey!wmain
seamonkey!__tmainCRTStartup
seamonkey!wmainCRTStartup

So I'm assuming -help doesn't set mXULAppDir, but it should.
Flags: blocking1.9.2?
(Assignee)

Comment 1

8 years ago
Created attachment 409587 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #409587 - Flags: review?(benjamin)

Updated

8 years ago
Severity: normal → critical
Keywords: crash
Summary: -help crashes → xulrunner -help crashes [@ LoadPlatformDirectory]

Updated

8 years ago
Attachment #409587 - Flags: review?(benjamin) → review+

Updated

8 years ago
Duplicate of this bug: 525441
(Assignee)

Comment 3

8 years ago
Pushed changeset ac5673902abd to mozilla-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Not blocking, but we should take the patch.
Flags: blocking1.9.2? → blocking1.9.2-
Attachment #409587 - Flags: approval1.9.2+
(Assignee)

Comment 5

8 years ago
Pushed changeset eca0dce6296c to releases/mozilla-1.9.2
status1.9.2: --- → final-fixed

Comment 6

8 years ago
turns out that lots of people seem to do do this.  its top crash in early 3.6b3 data.  re-asking for blocking so it gets a good flag an back on the radar if a regression happens with the landing.

see Bug 529482 for crash analysis
Flags: blocking1.9.2- → blocking1.9.2?
Flags: blocking1.9.2? → blocking1.9.2+

Comment 7

8 years ago
no reports of this on beta3 or 4 over the last couple of weeks.

there are reports on trunk and 3.5.5
http://crash-stats.mozilla.com/report/index/10dfc0f8-f1c0-4385-aee5-68cce2091203

and more at
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=contains&query=LoadPlatformDirectory&date=&range_value=2&range_unit=weeks&do_query=1&signature=LoadPlatformDirectory

does the patch need to go to other branches?

Updated

8 years ago
Duplicate of this bug: 529482
(Assignee)

Comment 9

8 years ago
(In reply to comment #7)
> does the patch need to go to other branches?
No, this particular crash should just be a regression from bug 521262.
Crash Signature: [@ LoadPlatformDirectory]
You need to log in before you can comment on or make changes to this bug.