Open Bug 526293 Opened 15 years ago Updated 2 years ago

Firefox file selector should show remote shares

Categories

(Core :: Widget: Gtk, defect, P2)

All
Linux
defect

Tracking

()

People

(Reporter: gliporace, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.1.4) Gecko/20091028 Ubuntu/9.10 (karmic) Firefox/3.5.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.1.4) Gecko/20091028 Ubuntu/9.10 (karmic) Firefox/3.5.4

Hi,
Firefox file selector in linux only support local file browsing (it doesn't show network places or bookmarked locations). For example, uploading a file from a remote folder (usually a common operation with user files stored in a NAS server) is not possible.
This same bug is reported in a Ubuntu Launchpad: 
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/31471


Reproducible: Always
(In reply to comment #1)
> See:
> https://bugzilla.mozilla.org/show_bug.cgi?id=402892

I don't think that gnome-vfs to gio has anything to do with it.
The native Gtk2 filechooser is never called to allow remote locations.

If appendFilters as declared in the idl:
https://mxr.mozilla.org/mozilla-central/source/widget/public/nsIFilePicker.idl#70
is set to filterAllowURLs the gtk filechoose is *_set_local_only false which would allow bookmarks of remote locations to show up.

I could not find any hint that this filter is set by any caller in Firefox but I'm not sure why and if it makes sense exactly the way it is done.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
Ubuntu 11.10 , Firefox 7 the same problem.

It`s crucial to have the network by default.
Marking as invalid as this is a bug with GTK not firefox.

Seee: https://bugzilla.gnome.org/show_bug.cgi?id=586367
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
The upstream bug has been fixed but Firefox still doesn't not work with remote mounts. Please reopen.
(In reply to Feng Yu from comment #7)
> The upstream bug has been fixed but Firefox still doesn't not work with
> remote mounts. Please reopen.

What Distro and what version of it are you running? Are you sure its got the updated version of GTK?
I've seen this with Fedora 21 and Fedora 22. Both were released long after the upstream was fixed.

The bug is still here. The file picker can see remote places, but only when Ci.nsIFilePicker.filterAllowURLs is passed to nsFilePicker::AppendFilters():

https://dxr.mozilla.org/mozilla-central/rev/bdfe643caf38aae40683a8229aac211021813c03/widget/gtk/nsFilePicker.cpp#227

Quick search reveals that filterAllowURLs is defined not it's not used anywhere.

Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Status: REOPENED → NEW
Priority: -- → P2
Component: General → Widget: Gtk
Product: Firefox → Core

Mike, what do you think about this bug? IMHO we should enable the network shares by default (as it's enabled in other gnome apps), is there any reason why it's disabled? I have Fedora/RHEL requests to enable it by default so Fedora/RHEL ships downstream patch for it.

Flags: needinfo?(mh+mozilla)

Looks like it depends how the remote location is mapped. This can lead to hidden failures when remote share is not handled.

Flags: needinfo?(mh+mozilla)

Any plans no enable it by default?

Is there a way no enable it in about:config, for example?

Is there any option in about:config i can change to enable this? (at my own risk)

As it is, it's very annoying and it's keeping us from working as well as we should.

Flags: needinfo?(stransky)

Yes, go to about:config and add Ci.nsIFilePicker.filterAllowURLs boolean key and set it to true. Firefox will see remote locations then.

Flags: needinfo?(stransky)

(In reply to Martin Stránský [:stransky] (ni? me) from comment #16)

Yes, go to about:config and add Ci.nsIFilePicker.filterAllowURLs boolean key and set it to true. Firefox will see remote locations then.

Hi,

Thank you but... i was already able to "see" the files and navigate into the samba directories with no problem.
The problem lies that when i select a file to upload it does nothing.

And, unless i missed something, this is still the case even with that key added to about:config

Did i done something wrong?

(In reply to Maverick from comment #17)

(In reply to Martin Stránský [:stransky] (ni? me) from comment #16)

Yes, go to about:config and add Ci.nsIFilePicker.filterAllowURLs boolean key and set it to true. Firefox will see remote locations then.

Hi,

Thank you but... i was already able to "see" the files and navigate into the samba directories with no problem.
The problem lies that when i select a file to upload it does nothing.

Yes, the problem is that Firefox doesn't contain code to handle remote shares properly, it works only when they're mounted directly to filesystem (AFAIK). When filepicker returns location which can't be accessed by regular file operation it silently fails - it's reason why it's disabled by default.

(In reply to Martin Stránský [:stransky] (ni? me) from comment #18)

(In reply to Maverick from comment #17)

(In reply to Martin Stránský [:stransky] (ni? me) from comment #16)

Yes, go to about:config and add Ci.nsIFilePicker.filterAllowURLs boolean key and set it to true. Firefox will see remote locations then.

Hi,

Thank you but... i was already able to "see" the files and navigate into the samba directories with no problem.
The problem lies that when i select a file to upload it does nothing.

Yes, the problem is that Firefox doesn't contain code to handle remote shares properly, it works only when they're mounted directly to filesystem (AFAIK). When filepicker returns location which can't be accessed by regular file operation it silently fails - it's reason why it's disabled by default.

Is there any other bug reports regarding this we should follow. It is pretty annoying to have to copy paste files from remote to local just to be able to upload them :(

On the KDE Plasma part this has been fixed in bug: https://bugs.kde.org/show_bug.cgi?id=444457

Can anyone confirm this also works well on GNOME?

If so, i believe we can close this bug as fixed!

I'd say that sshfs mount are shown

I have a nfs connection nsfs on /run/snapd/ns/canonical-livepatch.mnt type nsfs which is not shown.

(In reply to paolobenve from comment #21)

I'd say that sshfs mount are shown

I have a nfs connection nsfs on /run/snapd/ns/canonical-livepatch.mnt type nsfs which is not shown.

If you're on Ubuntu and using that "snap-thing", from what i know, it does not allow to browser remote folders... only the flatpack version.
(but i maybe wrong...)

Severity: normal → S3

The severity field for this bug is relatively low, S3. However, the bug has 3 duplicates.
:stransky, could you consider increasing the bug severity?

For more information, please visit auto_nag documentation.

Flags: needinfo?(stransky)

The last needinfo from me was triggered in error by recent activity on the bug. I'm clearing the needinfo since this is a very old bug and I don't know if it's still relevant.

Flags: needinfo?(stransky)
You need to log in before you can comment on or make changes to this bug.