Wrong OS_TEST value when cross compiling on Linux with mingw.

RESOLVED FIXED in mozilla1.9.3a1

Status

defect
RESOLVED FIXED
10 years ago
a year ago

People

(Reporter: jacek, Assigned: jacek)

Tracking

Trunk
mozilla1.9.3a1
x86
Other
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.3) Gecko/20091028 Gentoo Firefox/3.5.3
Build Identifier: 

OS_TEST is overwritten when OS_ARCH is WINNT:

case "$OS_ARCH" in
WINNT)
    OS_TEST=`uname -p`
    ;;

It should be unchanged when cross compiling.

Reproducible: Always
Assignee

Comment 1

10 years ago
Posted patch fixSplinter Review
Assignee

Updated

10 years ago
Attachment #409999 - Flags: review?(cls)
Assignee

Updated

10 years ago
Assignee: nobody → jacek
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 2

10 years ago
Comment on attachment 409999 [details] [diff] [review]
fix

The fix looks okay but incomplete. `uname -p` returns "unknown" for both cygwin & msys uname.  And there are bunch of other `uname` calls in that section that should not occur when cross-compiling.

rs=cls
Attachment #409999 - Flags: superreview?(ted.mielczarek)
Attachment #409999 - Flags: review?(cls)
Attachment #409999 - Flags: review+
Comment on attachment 409999 [details] [diff] [review]
fix

Yeah, because config.guess returns "i686-pc-mingw32" when building in MSYS, so we never hit that block, we hit this:
http://mxr.mozilla.org/mozilla-central/source/configure.in#1223
Attachment #409999 - Flags: superreview?(ted.mielczarek) → superreview+
Assignee

Comment 4

10 years ago
Thanks for reviews.
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/479d37add351
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Version: unspecified → Trunk

Updated

a year ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.