Download Manager Displays Unwanted Alert When Done

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
Download & File Handling
--
minor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: David E. Ross, Assigned: InvisibleSmiley)

Tracking

({fixed-seamonkey2.0.1})

Trunk
seamonkey2.1a1
fixed-seamonkey2.0.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: 

When I download and save by using the "Save Link Target As" item in the pull-down context menu on a link, I get an alert when done.  However, I have cleared the "Show an alert" checkbox on the Downloads pane of the Preferences window.  

Reproducible: Always

Steps to Reproduce:
1.  Go to <http://www.irs.gov/app/picklist/list/formsInstructions.html>.  

2.  In the Find input area, enter "1040" (without quote marks).  

3.  Select the Find button.  

4.  On the resulting window, right-click on the link "Form 1040" and select Save Link Target As from the pull-down context menu.  

5.  On the file selection window, select a place to save the file.  Select the Save button.  


Actual Results:  
An "All Downloads Complete" alert box appears in the lower-right corner of the browser window.  

Expected Results:  
No alert box should appear.
(Reporter)

Comment 1

8 years ago
Created attachment 410133 [details]
Screen shot with alert in lower-right corner.  

Screen shot shows browser window with Downloads Complete alert box in lower-right corner.
(Reporter)

Comment 2

8 years ago
Is it possible that clearing the "Show an alert" checkbox should be setting preference variable browser.download.manager.showAlertOnComplete to false?
(In reply to comment #2)
> Is it possible that clearing the "Show an alert" checkbox should be setting
> preference variable browser.download.manager.showAlertOnComplete to false?
This is exactly what that checkbox does.

Comment 4

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Is it possible that clearing the "Show an alert" checkbox should be setting
> > preference variable browser.download.manager.showAlertOnComplete to false?
> This is exactly what that checkbox does.

That may be what it's _supposed_ to do, but it's doing nothing for me, with "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0".  -JW

Updated

8 years ago
Component: Download Manager → Download & File Handling
Product: Toolkit → SeaMonkey
QA Contact: download.manager → download
(Assignee)

Comment 5

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Is it possible that clearing the "Show an alert" checkbox should be setting
> > preference variable browser.download.manager.showAlertOnComplete to false?
> This is exactly what that checkbox does.

No, it sets browser.download.finished_download_alert. Patch coming up.
Assignee: nobody → jh
Status: NEW → ASSIGNED
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
(Assignee)

Comment 6

8 years ago
Created attachment 410555 [details] [diff] [review]
use correct pref [Checkin: comment 7]

Simple pref change, applies to trunk and branch.
Attachment #410555 - Flags: superreview?(neil)
Attachment #410555 - Flags: review?(neil)
Attachment #410555 - Flags: approval-seamonkey2.0.1?

Updated

8 years ago
Attachment #410555 - Flags: superreview?(neil)
Attachment #410555 - Flags: superreview+
Attachment #410555 - Flags: review?(neil)
Attachment #410555 - Flags: review+

Updated

8 years ago
Attachment #410555 - Flags: approval-seamonkey2.0.1? → approval-seamonkey2.0.1+
(Assignee)

Comment 7

8 years ago
Comment on attachment 410555 [details] [diff] [review]
use correct pref [Checkin: comment 7]

http://hg.mozilla.org/comm-central/rev/64a6c87089f5
http://hg.mozilla.org/releases/comm-1.9.1/rev/878ea837f6c7
Attachment #410555 - Attachment description: use correct pref → use correct pref [Checkin: comment 7]
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: fixed-seamonkey2.0.1
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a1
(Reporter)

Comment 8

8 years ago
In which version of SeaMonkey is this fixed?  It's not in 2.0.1.
(Assignee)

Comment 9

8 years ago
(In reply to comment #8)
> In which version of SeaMonkey is this fixed?  It's not in 2.0.1.

It should be. Note that we only changed which pref is used for the checkbox under Preferences/Downloads so it should now reflect the correct pref. We didn't change any pref values, though. You should once again check that the checkbox is reflecting what you want since it might now show a different state than in SM 2.0.
You need to log in before you can comment on or make changes to this bug.