AIX Compilation error for 3.7a1pre source xpcom/io/nsFastLoadFile.cpp", line 884.13: 1540-0256 (S) A parameter of type "char *" cannot be initialized with an expression of type "PRUint8 *"

RESOLVED DUPLICATE of bug 526176

Status

()

--
major
RESOLVED DUPLICATE of bug 526176
9 years ago
9 years ago

People

(Reporter: shailen.n.jain, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

723 bytes, patch
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

While compiling Mozilla Firefox source for 3.7a1pre, getting
the below error.

"/home/firefox/mozilla-central/xpcom/io/nsFastLoadFile.cpp", line 884.13: 1540-0256 (S) A parameter of type "char *" cannot be initialized with an expression of type "PRUint8 *".
"/home/firefox/mozilla-central/xpcom/io/nsFastLoadFile.cpp", line 884.13: 1540-1205 (I) The error occurred while converting to parameter 1 of "madvise(caddr_t, size_t, int)".
gmake[1]: *** [nsFastLoadFile.o] Error 1


Reproducible: Always

Steps to Reproduce:
1. Build Mozilla Firefox 3.7a1pre build on AIX with Gnome RPMS of 64 bit
version.

2.
3.
Actual Results:  
Build fails with the above error.


Expected Results:  
No build failure
(Reporter)

Updated

9 years ago
OS: Other → AIX
(Reporter)

Comment 1

9 years ago
Created attachment 410205 [details] [diff] [review]
Patch V 1

The patch resolves the compilation error.
Attachment #410205 - Flags: review?(benjamin)

Updated

9 years ago
Attachment #410205 - Flags: review?(benjamin) → review?(tglek)

Comment 2

9 years ago
Comment on attachment 410205 [details] [diff] [review]
Patch V 1

I don't believe caddr_t exists on linux/osx.

if aix is like solaris 
bug 526176  will fix this
Attachment #410205 - Flags: review?(tglek) → review-

Comment 3

9 years ago
To clarify, instead of nesting more platform-specific defines, I'd rather rely on bug 526176 to rectify this situation.
Depends on: 526176
(Reporter)

Comment 4

9 years ago
Created attachment 411134 [details] [diff] [review]
Patch V 2

This behavior is similar to Solaris and hence attached the new patch
Attachment #410205 - Attachment is obsolete: true
Attachment #411134 - Flags: review?(tglek)

Comment 5

9 years ago
Shailen, has bug 526176 fixed AIX compile?
(Reporter)

Comment 6

9 years ago
yes the revised patch (of bug 526176) fixes the AIX compile

Updated

9 years ago
Attachment #411134 - Flags: review?(tglek)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526176
You need to log in before you can comment on or make changes to this bug.