Notification Bars: Half of the bar is shown when switching between tabs

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: aakashd, Assigned: wesj)

Tracking

({polish})

Bug Flags:
in-litmus ?

Details

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b2pre) Gecko/20091104 Firefox/3.6b2pre Fennec/1.0b5

Note: this issue (notification bar half-shown) is not seen if the user pans on the tab again and then switches back to that tab a second time.

Steps to Reproduce:
1. Go to www.popuptest.com/popuptest1.html and don't close the popup notification bar
2. Scroll down a bit so that the notification bar isn't viewable
3. Open a new tab and go to another site
4. Go back to the popuptest tab

Actual Results:
Pop up notification bar is half-shown and doesn't fully show until the person pans all the way to the top of the page

Expected Results:
the notification bar should be shown or not shown, but not half-shown when coming back.
Flags: in-litmus?
I think this is the same as bug 564285 (which was backed out in bug 569613, but not reopened for some reason - I think we decided to WONTFIX it but didn't update the bug).
OS: Linux (embedded) → All
Hardware: ARM → All
Version: 1.9.2 Branch → Trunk
Depends on: 564285
(Reporter)

Updated

7 years ago
Duplicate of this bug: 614658
(Reporter)

Updated

7 years ago
tracking-fennec: --- → ?
Wes - I think the notification bars should not be affected by scroll. Is this just the URLbar covering the notification bar?

If so, maybe we should make sure the urlbar is not obscuring the notification bar, when a notification is opened.
Assignee: nobody → wjohnston
tracking-fennec: ? → 2.0+
Hmm, is this still a problem?
(Reporter)

Comment 5

7 years ago
Yeah, its still happening on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101201 Namoroka/4.0b8pre Fennec/4.0b3pre

The scenario can be reproduced if you close the tab sidebar after step 4.
Aakash - Screenshot?
tracking-fennec: 2.0+ → 2.0-
Keywords: polish
(Reporter)

Comment 7

7 years ago
I'm not seeing this anymore on build
Mozilla/5.0 (Android; Linux armv71; rv:2.0b10pre) Gecko/20100120 Namoroka/4.0b10pre Fennec/4.0b4pre
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.