reftests/css-gradients/aja-linear-6a.html fails consistently on OSX < 10.6

NEW
Unassigned

Status

()

Core
Graphics
8 years ago
3 years ago

People

(Reporter: zwol, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
The reftest css-gradients/aja-linear-6a.html fails on OSX and only there.  Inspection of the images shows 13 pixels, in a diagonal line within the solid yellow region at the upper left hand corner, that are #ffff00 in the reference but #fefe00 in the test.  This is a divergence between a canvas gradient and a CSS gradient, so it might be our bug, but its only showing on OSX makes me think it's more likely to be a Quartz issue.

Attached is a tarball containing the parsed-out reftest images and an HTML wrapper that can be used to compare them easily.
(Reporter)

Comment 1

8 years ago
Created attachment 410441 [details]
failing reftest image bundle
Pushed http://hg.mozilla.org/mozilla-central/rev/3190bbe377cd to mark it as only failing on 10.5, since it passes on 10.6. Dunno whether that actually means we should resolve this NOTOURBUG or not, though.
Summary: reftests/css-gradients/aja-linear-6a.html fails consistently on OSX → reftests/css-gradients/aja-linear-6a.html fails consistently on OSX < 10.6

Comment 3

8 years ago
FWIW, I'm on 10.6, and it fails for me consistently as well.
Depends on: 1176496
You need to log in before you can comment on or make changes to this bug.