Closed Bug 526802 Opened 10 years ago Closed 8 years ago

Add about:crashes to the Troubleshooting Information page

Categories

(Toolkit :: General, enhancement)

enhancement
Not set

Tracking

()

VERIFIED FIXED
mozilla8

People

(Reporter: jmjjeffery, Assigned: xtc4uall)

References

(Blocks 1 open bug)

Details

(Whiteboard: [notacrash])

Attachments

(2 files, 1 obsolete file)

Under 'Help->Troubleshooting Information' I feel it would be helpful to add to the 'Application basics' area at the top of the page a URL / link to: about:crashes 

This would help support personnel in assisting end users to troubleshoot their issues with Firefox.
OS: Windows 7 → All
Hardware: x86 → All
Component: Menus → General
QA Contact: menus → general
Attached patch patch (obsolete) — Splinter Review
Bug 367596 comment 74 isn't that clear with adding "about:crashes" link on trunk or not. anyways, here's a patch that works for me.
Attachment #412295 - Flags: ui-review?(beltzner)
Attachment #412295 - Flags: review?(dao)
Comment on attachment 412295 [details] [diff] [review]
patch

As I understand it, bug 367596 comment 74 clearly says that this isn't wanted.

Feel free to re-request review once the ui-review is done.
Attachment #412295 - Flags: review?(dao)
Whiteboard: [notacrash]
Blocks: 580116
Product: Firefox → Toolkit
QA Contact: general → general
Duplicate of this bug: 580116
ui-review was requested 2 years ago. I have no idea if the patch is out of date. Is there someone else that can review it?

With regards to whether or not about:crashes is wanted in about:support...
I was the one who originally requested about:support, and the intent was to provide an easy way for users to provide info about their setup to support volunteers. If someone is experiencing crashes, "What are your latest crash IDs" is a common question from support volunteers, so I think this fits right in to about:support.

Right now, we ask for that info by telling the user to go to about:crashes, so this bug helps provide a UI path (Help > Troubleshooting Information > about:crashes). It's not really urgent for Firefox support.

The way I came across this bug is actually because of Thunderbird support, where the user doesn't have a location bar to type about:crashes. Right now, we can have them set the Mail Start Page to about:crashes, but I think this is definitely needed for Thunderbird.
Attachment #412295 - Flags: ui-review?(mbeltzner) → ui-review?(faaborg)
>"What are your latest crash IDs" is a common question from support volunteers, >so I think this fits right in to about:support.

perhaps add some of the recent crashes to "copy all to clipboard" to streamline this transfer of information?
Comment on attachment 412295 [details] [diff] [review]
patch

Technical, but no less so than super arcane details of the user's graphics drivers.  Also requested by support.
Attachment #412295 - Flags: ui-review?(faaborg) → ui-review+
Attached patch patchV2Splinter Review
Updated the Patch for Review since the TS Page lives in Toolkit now.
Attachment #412295 - Attachment is obsolete: true
Attachment #548653 - Flags: ui-review+
Attachment #548653 - Flags: review?(dao)
Attachment #548653 - Flags: review?(dao) → review+
XtC4UaLL, if you want this to be committed with your real name, please update the user info in the patch accordingly. Thanks!
Assignee: nobody → xtc4uall
Keywords: checkin-needed
Attached patch for checkinSplinter Review
Done. Thanks Dão ;-)
http://hg.mozilla.org/mozilla-central/rev/42b1ad712868
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla8
Verified fixed using cset:
http://hg.mozilla.org/mozilla-central/rev/e4c8a1e7b373
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.