Large XML file crashes browser and generates extremely high CPU/memory loads

VERIFIED DUPLICATE of bug 291643

Status

()

Core
XML
--
critical
VERIFIED DUPLICATE of bug 291643
8 years ago
7 years ago

People

(Reporter: Alexander Fefer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

After navigating to the URL (http://www.cmegroup.com/wrappedpages/clearing/pbrates/MarginRates.xml) which is a huge 15MB XML file, the loading time is very long (30-60 seconds) with the machine periodically becoming unresponsive. Occasionally when navigating to/from the offending tab, Firefox will crash outright as described below. CPU and memory loads go to 100%.

Another user reported the following behavior:

Second time loading of the same page the machine was again sometimes not
responding, and i tried to switch to another FF tab (one of about ten) and this
worked after a while, but when going back to the slow tab again, and while
freezing, Firefox closed with this error:

Windows Error box:
"Microsoft Visual C++  Runtime library

(red cross)  
Runtime error!
Program C:\Program Files\Mozilla Firefox\Firefox.exe

This application has requested the runtime to terminate it in an unusual way.
Please contact the application's supoport team for more information.
OK"

Reproducible: Always

Steps to Reproduce:
1. Navigate to URL of very large XML file.
Actual Results:  
Extremely unresponsive system, CPU and memory loads go to 100%, browser occasionally crashes.

Expected Results:  
The XML file should be opened without crashing or becoming unresponsive and with minimal CPU/memory loads. Note: Internet Explorer 8.2 demonstrates correct behavior.

Fails on:
C2D T9300 Windows 7 Ultimate up-to-date, FF 3.5.4, 4GB installed.
C2D E6600 Windows XP Pro up-to-date, FF 3.5.4, 4GB installed.
Confirming using  Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b6pre) Gecko/20091231 Namoroka/3.6b6pre, but I don't get the runtime errors. I also crashed once - http://crash-stats.mozilla.com/report/index/bp-2544c346-c432-4f8c-b29b-889762091231

IE also has a difficult time loading this site and it froze too. In fact, my entire system froze and I had to reboot this win 7 x64 machine.
Status: UNCONFIRMED → NEW
Ever confirmed: true
It would be nice to get the crash stacks that the original reporter got to see if they match what I got.

Comment 3

8 years ago
Marcia: that's bug 536224, it might or might not be the same bug....

Comment 4

7 years ago
We see this in the Red Hat bug report https://bugzilla.redhat.com/show_bug.cgi?id=608691 Closing that bug as a duplicate of this one.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 291643

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.