Closed Bug 52683 Opened 21 years ago Closed 21 years ago

text fields show up highlighted for object dialogs

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

VERIFIED INVALID

People

(Reporter: sujay, Assigned: rubydoo123)

Details

using 9/14 build of netscape

1) launch netscape
2) launch composer
3) insert object(image or H. line, or etc.)
4) double click on the object you just inserted.

notice the first field is highlighted with the value..

it shouldn't be highlighted...

all platforms.
Huh? Why not! Seems like correct behavior to me.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
Then how come it hasn't been in the product all along ??

Users don't always want top edit a field when they open up
an object dialog ???

It was always the intended behavior and has been that way for a couple of 
weeks, although focus problems often broke it. If the don't want to edit
the first field, they just click somewhere else or in that field to set focus
(caret) if they don't want to replace entire value. Fairly typical dialog 
behavior, at least on Windows. At least we don't select the entire edit field
*ever* time you click in it, which is typical Window behior that is aweful!
OK...the reason I filed it as a bug is because this behavior was never
in the product and all of a sudden I saw it.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.