The default bug view has changed. See this FAQ.

create Lightning build servers for comm-central/mozilla-central repository

RESOLVED FIXED

Status

Calendar
Build Config
--
enhancement
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Stefan Sitter, Assigned: gozer)

Tracking

Details

(Reporter)

Description

8 years ago
I'd suggest to create Lightning build servers for comm-central/mozilla-central repository to ensure that the calendar code is not (too much) broken by changes in toolkit or thunderbird 3.1 or both.
I agree. gozer, can you make this happen?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

8 years ago
(In reply to comment #1)
> I agree. gozer, can you make this happen?

Yes, I think the simplest thing would be to do just like we are doing for thunderbird. Keep the current build boxes, but get them building both branches. If that works for you guys, I can probably make it so early next week.

Would you want them reporting to the same Sunbird tinderbox tree, or go split tinderbox trees like TB/TB3.0 ? If the answer is 2 trees, you'll need to get MoCo IT to create it ahead of time.
(In reply to comment #2)
> Would you want them reporting to the same Sunbird tinderbox tree, or go split
> tinderbox trees like TB/TB3.0 ? If the answer is 2 trees, you'll need to get
> MoCo IT to create it ahead of time.

You don't need MoCo IT to create another tinderbox tree - any tinderbox admin can do that (and I can do that).
(Assignee)

Comment 4

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Would you want them reporting to the same Sunbird tinderbox tree, or go split
> > tinderbox trees like TB/TB3.0 ? If the answer is 2 trees, you'll need to get
> > MoCo IT to create it ahead of time.
> 
> You don't need MoCo IT to create another tinderbox tree - any tinderbox admin
> can do that (and I can do that).

Ah, okay, Tinderbox admin then. In any case, the decision on how to report to tinderbox (Sunbird/Sunbird3.0 for instance) still needs to be made before we can make it so.
Since it doesn't seem to be a lot of work, I'd go for a separate tree like TB/TB3.0
(Assignee)

Comment 6

8 years ago
Standard8, can you go ahead and create a Sunbird3.0 tree in tinderbox?
(In reply to comment #6)
> Standard8, can you go ahead and create a Sunbird3.0 tree in tinderbox?

Maybe we should call it something with "Calendar" not "Sunbird", because Lightning is the main product now.
(In reply to comment #7)
> (In reply to comment #6)
> > Standard8, can you go ahead and create a Sunbird3.0 tree in tinderbox?
> 
> Maybe we should call it something with "Calendar" not "Sunbird", because
> Lightning is the main product now.

I'm happy any way - Calendar1.0 or something like that (note that we'd have to have the trunk one remaining as Sunbird or move it across to just Calendar).
Calendar1.0 tree is alive and ready to go:

http://tinderbox.mozilla.org/showbuilds.cgi?tree=Calendar1.0

I'll sort out what to do wrt Sunbird -> Calendar later in the week.
(Assignee)

Comment 10

8 years ago
Buildbot master changed for trunk lightning builds:

changeset:   1719:595495248c4e
tag:         tip
user:        Philippe M. Chiasson <gozer@mozillamessaging.com>
date:        Tue Nov 10 11:07:21 2009 -0500
summary:     Bug 527065 - Create trunk lightning builds

For now, sending status to ThunderbirdTest tinderbox tree
(Reporter)

Comment 11

8 years ago
Do I understand it correctly? Current comm-1.9.1/mozilla-1.9.1 builds will be moved to <http://tinderbox.mozilla.org/showbuilds.cgi?tree=Calendar1.0>. At least the version number and comment on the page indicate this.

The new comm-central/mozilla-central builds will report where? Maybe to CalendarTest until there is a decision about the future roadmap?
(In reply to comment #11)
> The new comm-central/mozilla-central builds will report where? Maybe to
> CalendarTest until there is a decision about the future roadmap?

In a discussion I had with Fallen last night, they will currently report to Sunbird. Once I find out about the best way to move across, they will report to Calendar.
(Assignee)

Comment 13

8 years ago
cb-sb-linux-tbox.sj.mozilla.com was missing libnotify-devel wireless-tools-devel, installed.
(Assignee)

Comment 14

8 years ago
cb-xserve03 needs the latest Xcode
(Assignee)

Comment 15

8 years ago
Win32 and Linux are now green.
(Assignee)

Comment 16

8 years ago
cb-xserve03 updated to Xcode 3.1, OS X trunk builds went green.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

8 years ago
Is it possible to delay the comm-central nightly builds by one or two hours to ensure that comm-1.9.1 nightly builds are produced first?

Updated

5 years ago
Assignee: nobody → gozer
You need to log in before you can comment on or make changes to this bug.