If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Nanojit should have 8/16 bit load-with-sign-extend operations

VERIFIED DUPLICATE of bug 527083

Status

Tamarin
Baseline JIT (CodegenLIR)
VERIFIED DUPLICATE of bug 527083
8 years ago
8 years ago

People

(Reporter: Steven Johnson, Assigned: Steven Johnson)

Tracking

Details

(Assignee)

Description

8 years ago
Nanojit currently offers 8-bit and 16-bit load operations (ldcb and ldcs) that zero-extend, but no equivalent with sign-extend. We can simulate with the existing instructions + shifts, but since pretty much all interesting processors provide a single instruction to do this directly, it would be vastly more efficient to include this as a nanojit primitive.
(Assignee)

Comment 1

8 years ago
Scope creep: additionally, it really needs to provide volatile versions of the existing 8/18 load operations, since not all uses are likely to be CSE-able.
(Assignee)

Updated

8 years ago
Blocks: 458279
(Assignee)

Comment 2

8 years ago
Prototype patch for this is included in a patch for bug 527083.
Blocks: 520714
(Assignee)

Comment 3

8 years ago
fixed as part of https://bugzilla.mozilla.org/show_bug.cgi?id=527083
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Assignee: nobody → stejohns

Updated

8 years ago
Status: RESOLVED → VERIFIED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 527083
You need to log in before you can comment on or make changes to this bug.