Private MathML attributes should not be accessible from DOM

RESOLVED FIXED in mozilla29

Status

()

Core
MathML
P5
normal
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: fredw, Assigned: fredw)

Tracking

Trunk
mozilla29
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

8 years ago
Created attachment 410943 [details]
Testcase

MathML use several private attributes to implement "columnalign", "columnline", "rowalign", "rowline" (mtable attributes) and "fontstyle" (in particular to make <mi>x</mi> italic). They are used to apply CSS style via mathml.css. These attributes are currently accessible from DOM while they are not standard.
	
	I try to fix bug 475518 to see whether following the right syntax _moz* helps, but apparently it does not work.
	
	See also http://groups.google.fr/group/mozilla.dev.tech.mathml/browse_thread/thread/fd3e7defcdfb2b4f
(Assignee)

Updated

7 years ago
Depends on: 69409
(Assignee)

Comment 1

7 years ago
(In reply to comment #0)
> Created attachment 410943 [details]
> Testcase

It seems that this bug is fixed on trunk. At least, the private attributes are no longer caught by the testcase...
Created attachment 490073 [details] [diff] [review]
Mochitest patch for revealing _moz- attributes when running the html5lib test suite

There are still 12 test cases in the html5lib test suite that show this problem. E.g. <!DOCTYPE html><body><table><math><mi>foo</mi></math></table>

Attaching a patch that reveals these when running
parser/htmlparser/tests/mochitest/test_html5_tree_construction_part2.html
Duplicate of this bug: 594420
(Assignee)

Comment 4

7 years ago
Created attachment 490486 [details]
Testcase

Update the reduced testcase.
Attachment #410943 - Attachment is obsolete: true
(Assignee)

Comment 5

5 years ago
(In reply to Frédéric Wang (:fredw) from comment #4)
> Created attachment 490486 [details]
> Testcase
> 
> Update the reduced testcase.

Note: the test is not valid MathML because rowalign and columnalign attributes are reversed. But it detects the private _moz attributes anyway.
(Assignee)

Updated

5 years ago
Priority: -- → P5
(Assignee)

Comment 6

4 years ago
https://tbpl.mozilla.org/?tree=Try&rev=51ab041e5ec1
(Assignee)

Comment 7

3 years ago
Created attachment 8347313 [details] [diff] [review]
Patch V2
Attachment #490073 - Attachment is obsolete: true
(Assignee)

Comment 8

3 years ago
Comment on attachment 8347313 [details] [diff] [review]
Patch V2

After bugs 731667 and 114365, all the private _moz attributes have been removed. So I believe this patch can now be taken.
Attachment #8347313 - Flags: review?(hsivonen)
(Assignee)

Comment 9

3 years ago
https://tbpl.mozilla.org/?tree=Try&rev=872a4d156e59
Comment on attachment 8347313 [details] [diff] [review]
Patch V2

Awesome! Thank you.
Attachment #8347313 - Flags: review?(hsivonen) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc7b5f21be2c
Assignee: nobody → fred.wang
Flags: in-testsuite-
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/bc7b5f21be2c
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.