Closed Bug 527299 Opened 13 years ago Closed 12 years ago

Cannot translate string "Go to the contributor home page, or log out" on SUMO homepage

Categories

(support.mozilla.org :: Localization, task)

x86
Windows Vista
task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: JasnaPaka, Assigned: cilias)

References

()

Details

(Whiteboard: sumo_only)

I active interactive translator and I try to localize string "Go to the contributor home page, or log out" on SUMO homepage.

Original string:
Go to the <a href="Contributor Home Page">contributor home page</a>, or <a href="/tiki-logout.php">log out</a>.

My translation to czech (cs):
Přejděte na <a href="Contributor Home Page">domovskou stránku přispěvatele</a> nebo se <a href="/tiki-logout.php">odhlašte</a>.

After submit is my translation lost. Maybe for string "Find out how to contribute, or log in." is the same problem.
Here's the module markup:
<div id="wantgetinvolved" class="module">
	<div id="wantgetinvolved-title" class="title">{tr}Want to get involved?{/tr}</div>
	<div id="blankblock" class="fltrt"></div>
	<div id="wantgetinvolved-text">
	{tr}Did you know that most of the content on Firefox Support was written by volunteers?{/tr}<br/>
	</div>
	{if $user eq ""}{tr}<a href="/kb/How+to+contribute">Find out how to contribute</a>, or <a href="/tiki-login.php">log in</a>.{/tr}{else} {tr}Go to the <a href="Contributor+Home+Page">contributor home page</a>, or <a href="/tiki-logout.php">log out</a>.{/tr}{/if}
</div>

Maybe the problem is that the URLs are within the {tr} tags?
Whiteboard: sumo_only
Target Milestone: --- → 1.6
Assignee: nobody → paulc
Target Milestone: 1.6 → 1.5.1
I'll try using separate strings on stage, so there are no {tr} tags with URLs inside.
Target Milestone: 1.5.1 → 1.6
Target Milestone: 1.6 → 1.5.1
Here's a new version of the module, that should work.
	<div id="wantgetinvolved-title" class="title">{tr}Want to get involved?{/tr}</div>
	<div id="blankblock" class="fltrt"></div>
	<div id="wantgetinvolved-text">
	{tr}Did you know that most of the content on Firefox Support was written by volunteers?{/tr}<br/>
	</div>
	{if $user eq ""}<a href="/kb/How+to+contribute">{tr}Find out how to contribute{/tr}</a>, {tr}or{/tr} <a href="/tiki-login.php">{tr}log in{/tr}</a>.{else} {tr}Go to the{/tr} <a href="Contributor+Home+Page">{tr}contributor home page{/tr}</a>, {tr}or{/tr} <a href="/tiki-logout.php">{tr}log out{/tr}</a>.{/if}

Can someone test it on <https://support-stage.mozilla.com>? The unfortunate part of this is stings like "or" are independent strings.
Assignee: paulc → bmo2010
If there's a backend fix, that doesn't split up the strings, that is preferred.
Works fine. Just small problem with char "," which is before "{tr}or{/tr}". In czech translation shouldn't be such char there. What about change to "{tr}, or{/tr}"?
Okay, looks like this is the way we are going to fix it.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Agree with Pavel, the comma should be inside the {tr} since not all languages will actually use it. 

Same with the unfortunate "." at the end, which I know isn't used in Japanese. Not sure how we can work around that without making the period part of the link target though...
I've modified the module 'wantgetinvolved' per comment 5 and then tested on sv-SE. However, I can't get the string "Find out how to contribute" to show up translated when logging out. All other strings seem to work.

Note that this is a string you have to add manually since you can't use the interactive translator (since the string is only visible when you're logged out). I added the string to sv-SE with the correct translation.

I've waited 30 minutes now, so I'm starting to doubt it's a cache issue.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Apparently it works on https://support-stage.mozilla.com/it/kb/ so it must be something I'm doing wrong with sv-SE. 

Chris, can you help me fix sv-SE when you got the time?
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
...and now it works in sv-SE. Indeed, it was a caching issue. Yay!
Status: RESOLVED → VERIFIED
Applied to prod.
(In reply to comment #7)
> Same with the unfortunate "." at the end, which I know isn't used in Japanese.
> Not sure how we can work around that without making the period part of the link
> target though...

I want to add some words to the place of "." in Japanese.
It will be as follows:

<a href="/kb/How+to+contribute">{tr}貢献者ガイドを読む{/tr}</a> {tr}か{/tr} <a href="/tiki-login.php">{tr}ログイン{/tr}</a> {tr}してください。{/tr}{else} {tr}{/tr} <a
href="Contributor+Home+Page">{tr}貢献者ホームページ{/tr}</a> {tr}を開くか{/tr} <a
href="/tiki-logout.php">{tr}ログアウト{/tr}</a> {tr}する。{/tr}
marsf: you can do this from https://support.mozilla.com/tiki-edit_languages.php. You need to add the following translated strings to Japanese:

"Find out how to contribute"
"Go to the"
"contributor home page"
", or"
"log in"
"log out"

I tried to modify the template to use {tr}.{/tr} at the end, so "." could be translated to "" in Japanese, but for some reason (Tiki bug?) that didn't work. This means that unfortunately right now, the period is not possible to remove.

A lot of these limitations is due to how the translation system works in TikiWiki. The upcoming SUMO 2.0 will not have these problems (https://wiki.mozilla.org/Support/Kitsune), but for now, unfortunately there's not a lot we can do. :(
ok.
I've changed the line to:
"貢献者ガイドを読む | ログイン." 
"貢献者ホームページ | ログアウト."

This will not depend to any language.

"Find out how to contribute" -> "貢献者ガイドを読む"
"Go to the" -> ""
"contributor home page" -> "貢献者ホームページ"
", or" -> " | "
"log in" -> "ログイン"
"log out" -> "ログアウト"
You need to log in before you can comment on or make changes to this bug.