Closed Bug 527610 Opened 13 years ago Closed 13 years ago

Add a confirmation dialog to the "Start New Session" button in the crash page

Categories

(Firefox :: Session Restore, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Simon80, Unassigned)

Details

(Keywords: dataloss)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4) Gecko/20091028 Iceweasel/3.5.4 (Debian-3.5.4-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4) Gecko/20091028 Iceweasel/3.5.4 (Debian-3.5.4-1)

I just accidentally hit the "start new session" button after a crash, losing a few different windows full of tabs, representing everything I was doing with my browser at this point in time. This was a serious loss of information for me, so I think that there should be a confirmation dialog in place to prevent this from happening, or better yet, some kind of session history that I could use to resurrect the session I just accidentally nuked.

Reproducible: Always

Steps to Reproduce:
1. Kill firefox
2. Pick "Start New Session"
Actual Results:  
Loss of existing session.

Expected Results:  
A second chance to avoid losing my entire session.
After accidentally clicking on "Start new Session" you can type "about:sessionrestore" into the location bar and you'll get the restore page again. Furthermore there is already a bug filed for trying to resolve that problem: bug 477322. I prefer to differ the buttons since a dialog box is annoying (at least when there is no "Never ask again" checkbox).
Component: Tabbed Browser → Session Restore
OS: Linux → All
QA Contact: tabbed.browser → session.restore
Hardware: x86_64 → All
Whiteboard: dupeme?
Yes, we can dupe to bug 477322.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme?
This bug proposes a confirmation prompt as a certain solution. So far, bug 477322 has gone in a different direction.

(In reply to comment #1)
> I prefer to differ the buttons since a dialog box is
> annoying (at least when there is no "Never ask again" checkbox).

Isn't "Restore" the option you'd take in most cases? Based on that, a prompt for "Start New Session" wouldn't be annoying.
Blocks: 477322
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss
(In reply to comment #3)
> (In reply to comment #1)
> > I prefer to differ the buttons since a dialog box is
> > annoying (at least when there is no "Never ask again" checkbox).
> 
> Isn't "Restore" the option you'd take in most cases? Based on that, a prompt
> for "Start New Session" wouldn't be annoying.

Fair enough.
Note that we already have an (only slightly inobvious) Undo button for when you accidentally click on "Start New Session": the Back button.
I completely didn't notice the back button. It would have made me very happy to discover that while it was still useful.
The back button absolutely doesn't solve this bug, as people don't expect that "Start New Session" actually means to navigate from this page (this part many won't get already, as it's a chrome message) to the home page.
Fully agreed on the need for a verification prompt for "Start New Session".  I have done this several times myself, and always with very frustrating results.  After very carefully selecting the tabs to restore and discard, I click on "start", without carefully reading the button names.  I usually avoid this mistake, but sometimes when I'm already juggling a few other topics in my mind, I just click without really thinking.

Fortunately on this occasion (when I really lot a lot of info on my session), I have found the workaround from this thread and recovered my session.  However for the average user who does not think to delve into Bugzilla, the verification prompt would be very beneficial.
--> WONTFIX
We're getting rid of the "Start New Session" button in bug 477322.
No longer blocks: 477322
Status: NEW → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.