Closed Bug 527621 Opened 10 years ago Closed 10 years ago

Drag and drop to another window causes unfocusable window

Categories

(Core :: DOM: Drag & Drop, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 429166

People

(Reporter: barnett.thomas, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

When selected text is dropped from one window to another window's search box, dropped window becomes unresponsive to clicks with the error:

Error: transferData.first is null
Source file: chrome://global/content/nsTransferable.js
Line: 459

The click event on dropped window is affected on dropping window




Reproducible: Always

Steps to Reproduce:
1. Open first window (A) and navigate to any URL 
2. Open a second window (B)
3. Select text in A and drop in search box in B. 
Actual Results:  
Search results will open in A. From this point on left clicks on B will focus A instead. Activating a menu item in B or to close B will not be possible.

Expected Results:  
Search results will open in B. B will continue accept clicks

After Step 3, right click will bring up the left click focus back but closing B will now produce the error:

Error: uncaught exception: [Exception... "'[JavaScript Error: "this.ctxItem is undefined" {file: "file:///C:/Documents%20and%20Settings/user/Application%20Data/Mozilla/Firefox/Profiles/8e0o6onn.default/extensions/%7Bb9db16a4-6edc-47ec-a1f4-b86292ed211d%7D/components/dhCore.js" line: 1329}]' when calling method: [dhICore::unregisterContextItem]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://dwhelper/content/menu.xml ::  :: line 83"  data: yes]
This is a duplicate.
Whiteboard: [DUPEME]
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME]
Duplicate of bug: 429166
You need to log in before you can comment on or make changes to this bug.