New startup crash [@ nsThreadManager::Init()] in 3.5.5

RESOLVED DUPLICATE of bug 526586

Status

()

RESOLVED DUPLICATE of bug 526586
9 years ago
8 years ago

People

(Reporter: jst, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
So far we've seen 923 crashes in 3.5.5 with the signature nsThreadManager::Init(), which is a signature we've never seen in any other 3.5 release, which means it was most likely introduced in 3.5.5. The stacks seem to all look like the one in this crash report

http://crash-stats.mozilla.com/report/index/635ae815-847f-4339-97b6-8b9372091110

And it looks like every single crash is on Windows NT 5.1.2600, which I think means XP.

And there's 3 of these crashes reported on trunk as well, so likely a problem there too, just not seen as much yet due to the small number of users there still.

This is a crash regression, I think we should attempt to fix this before 1.9.2 goes out the door.
Flags: blocking1.9.2?
(Reporter)

Comment 1

9 years ago
Dbaron mentioned that this might be related to the fix for bug 521750.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526586

Comment 3

9 years ago
Interesting to see this in a non-embedding situation, unless somebody is using a xulrunner stub with the Firefox libxul or something else weird like that.
Summary: New nsThreadManager::Init() startup crash in 3.5.5 → New startup crash [@ nsThreadManager::Init()] in 3.5.5
Flags: blocking1.9.2?
status1.9.1: ? → ---
You need to log in before you can comment on or make changes to this bug.