Closed Bug 527943 Opened 10 years ago Closed 10 years ago

Row highlights when user clicks on input field within that row

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
defect
Not set

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0
Tracking Status
fennec 1.0+ ---

People

(Reporter: aakashd, Assigned: stechz)

Details

(Whiteboard: [polish])

Attachments

(1 file, 1 obsolete file)

Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b3pre) Gecko/20091111 Firefox/3.6b2pre Fennec/1.0b5

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091111 Firefox/3.7a1pre Fennec/1.0b5

Steps to Reproduce:
1. Open up the awesome bar and click on "see all bookmarks"
2. Click on the manage button
3. Click on the user field multiple times in different areas

Actual Results:
The row highlights each time and it gets annoying when I make a mistake inputting a field for my bookmark and tapping/mousedown'ing on that entry.

Expected Results:
In manage mode with the row already selected, the user doesn't need highlighting because they've already chosen it and are making changes to it. This can also be applied to the addons manager when users are selecting different input fields for options of an installed addon.
Flags: in-litmus?
tracking-fennec: --- → ?
Can we not highlight the row when a tap is on an input field?  On buttons too, for that matter.
tracking-fennec: ? → 1.0+
Whiteboard: [polish]
Assignee: nobody → webapps
Attached patch Cheat (obsolete) — Splinter Review
As discussed on IRC, it doesn't really make sense to highlight a row when clicking on it would do absolutely nothing, as is the case for a selected row with input fields shown.  So we can cheat on this issue if you agree.
Attachment #415678 - Flags: ui-review?
Attachment #415678 - Flags: review?(mark.finkle)
Attachment #415678 - Flags: ui-review? → ui-review+
Comment on attachment 415678 [details] [diff] [review]
Cheat

We should think about richlistitems in general, like the ones used for addons and downloads. Both of those "open" when selected too.
Attachment #415678 - Flags: review?(mark.finkle) → review+
Yes - definitely -- I think people will encounter this a lot more in add-ons than in editing bookmarks.
Attached patch Code reviewSplinter Review
Think this covers downloads, extensions, and bookmarks.
Attachment #415678 - Attachment is obsolete: true
Attachment #415721 - Flags: review?(mark.finkle)
Attachment #415721 - Flags: review?(mark.finkle) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/e6c33d19dce8
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
verified FIXED On builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091204 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091204 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
This is obvious enough that even if its not mentioned in our testsuite, it'll be annoying to the point that users will file a bug right away.
Flags: in-litmus? → in-litmus-
You need to log in before you can comment on or make changes to this bug.