Closed Bug 527986 Opened 10 years ago Closed 10 years ago

new tabs open with partial thumbnail of old tab

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
x86
macOS
defect
Not set

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0
Tracking Status
fennec 1.0+ ---

People

(Reporter: madhava, Assigned: vingtetun)

References

Details

Attachments

(2 files, 2 obsolete files)

When I open a new tab, it gets a weirdly scaled copy of the thumbnail of the tab I was on when I opened the new tab.

See here: http://www.flickr.com/photos/madhava_work/4096296146/

It should be blank.
tracking-fennec: --- → ?
Flags: in-litmus?
tracking-fennec: ? → 1.0+
Assignee: nobody → 21
Duplicate of this bug: 525337
Attached patch Patch (obsolete) — Splinter Review
This patch remove an unneeded call to updateThumbnail is the loaded page is about:blank by setting the background-color default of the tab as white.
Attachment #413865 - Flags: review?(mark.finkle)
Why change to specifying a border color identical to the background rather than using transparent?

I also don't really see the point of the border-radius change - doesn't make sense to specify it for a border that is invisible.
tracking-fennec: 1.0+ → ---
Huh, I have no idea how I managed to reset blocking-fennec...
tracking-fennec: --- → ?
tracking-fennec: ? → 1.0+
(In reply to comment #3)
> Why change to specifying a border color identical to the background rather than
> using transparent?

That's because otherwise the background-color is visible. (see attachement)

> I also don't really see the point of the border-radius change - doesn't make
> sense to specify it for a border that is invisible.

You're right, I don't see any good reasons to do that.
Attached patch Patch v0.2 (obsolete) — Splinter Review
Updated patch
Attachment #413865 - Attachment is obsolete: true
Attachment #413924 - Flags: review?(gavin.sharp)
Attachment #413865 - Flags: review?(mark.finkle)
Attached patch PatchSplinter Review
Fix the missing color for borders
Attachment #413924 - Attachment is obsolete: true
Attachment #413941 - Flags: review?(gavin.sharp)
Attachment #413924 - Flags: review?(gavin.sharp)
Attachment #413941 - Flags: review?(gavin.sharp) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/8827852cdf72
Status: NEW → RESOLVED
tracking-fennec: 1.0+ → ---
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
tracking-fennec: --- → ?
tracking-fennec: ? → 1.0+
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b4pre) Gecko/20091123 Firefox/3.6b4pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091123 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
Litmus testcase https://litmus.mozilla.org/show_test.cgi?id=7095 has been updated to regression test this bug.
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.