Assertions "parent node must have _DOMElement set" fire when bookmarking new URLs.

RESOLVED DUPLICATE of bug 528006

Status

()

defect
RESOLVED DUPLICATE of bug 528006
10 years ago
9 years ago

People

(Reporter: mozbugz, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091112 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091112 Minefield/3.7a1pre

I keep seeing odd assertions:

I had a large one using the bookmark this page function,

ASSERT: parent node must have _DOMElement set
Stack Trace:
0:PMV_nodeInserted([object ResultNodeClassInfo],[object ResultNodeClassInfo],35)
1:insertBookmark(2,[xpconnect wrapped nsIURI],-1,Bug 521966 – Flickering cursor while dragging over a possible drop target spot)
2:PCIT_doTransaction()
3:doTransaction([xpconnect wrapped nsITransaction])
4:placesTxn_doTransaction([xpconnect wrapped nsITransaction])
5:doTransaction([xpconnect wrapped nsITransaction])
6:PCH_bookmarkPage([object XULElement],2,true)
7:PCH_bookmarkCurrentPage(true,2)
8:oncommand([object XULCommandEvent])

Hit cancel I get another Assertion.

ASSERT: parent node must have _DOMElement set
Stack Trace:
0:PMV_nodeRemoved([object ResultNodeClassInfo],[object ResultNodeClassInfo],35)
1:moveItem(1470,65,-1)
2:PMIT_doTransaction()
3:doTransaction([xpconnect wrapped nsITransaction])
4:placesTxn_doTransaction([xpconnect wrapped nsITransaction])
5:doTransaction([xpconnect wrapped nsITransaction])
6:EIO_onFolderMenuListCommand([object XULCommandEvent])
7:oncommand([object XULCommandEvent])


I went to select a bookmark folder in the bookmark dialog.

And I keep getting this one..

ASSERT: node must have _DOMElement set
Stack Trace:
0:PMV_nodeIconChanged([object ResultNodeClassInfo])

Reproducible: Always

Steps to Reproduce:
1. Navigate to a bug you haven't bookmarked
2. Go to Bookmarks Menu, Bookmark This Page
3. See assertion 1.

1. Select folder
2. See assertion 2.

1. Either open a bookmark in a new tab
2. See assertion 3.
Actual Results:  
Yucky assertions are thrown..

Expected Results:  
Not see assertions.

Started with 20091112 trunk that I know of so far.
Reporter

Updated

10 years ago
Version: unspecified → Trunk
can you reproduce in Safe Mode? http://support.mozilla.com/kb/Safe+Mode
Which add.ons do you have? the bug could be valid but we need to be sure it is not caused by an add-on.
Keywords: qawanted
Blocks: 498130
Summary: Assertions fire when bookmarking new URLs. → Assertions "parent node must have _DOMElement set" fire when bookmarking new URLs.
Also have you customized your bookmarks toolbar before?
Reporter

Comment 3

10 years ago
Well, I have no customizations or add-ons installed (I only had AVG items which were disabled).  I tried safe-mode and didn't see it, which I expected.  Though I may have used one version build on profile that maybe wasn't compatible with a profile with which it was created.  And then used Minefield again.   I had run an hourly build when I had started seen this after I installed the 10-12 nightly file.
Reproduced on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1) Gecko/20100208 MozillaDeveloperPreview/3.7a1 (.NET CLR 3.5.30729)

Repro:
1) install Fx3.7alpha 1 developer preview
2) find any website 
3) bookmark the page (through bookmark tools or star menu)
4) now try unbookmarking, adding a tag, any other action
5) Verify assert popups thrown.

attaching screenshot
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 528006
You need to log in before you can comment on or make changes to this bug.