Date.toLocaleFormat doesn't accept %T on Windows

RESOLVED DUPLICATE of bug 818634

Status

()

RESOLVED DUPLICATE of bug 818634
9 years ago
9 months ago

People

(Reporter: mstange, Unassigned)

Tracking

Trunk
All
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
This is what caused bug 527747.

When you use %T in toLocaleFormat on Windows, it discards the format completely and uses the standard format, so that you get something like this:
Fri Nov 13 2009 18:10:14 GMT+0100

When I run the testcase (see URL) on Mac, I get 18:10:14 instead, which is correct.
Unfortunately, toLocaleFormat just calls the system strftime, so platform compatibility isn't available. It would be better if we could have a cross platform implementation instead.
(Assignee)

Updated

4 years ago
Assignee: general → nobody
toLocaleFormat was removed in bug 818634.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818634
You need to log in before you can comment on or make changes to this bug.