Middle click on last tab shows close button for a split of second when browser.tabs.closeWindowWithLastTab=false

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b3pre) Gecko/20091113 Namoroka/3.6b3pre (.NET CLR 3.5.30729) ID:20091113051922

With the following steps the close button of the last tab is visible for a split of second when trying to close the last tab with a middle click. This behavior is only visible on 1.9.2 and 1.9.1. I cannot reproduce it on trunk. Further I haven't found an existing bug which could have fixed that behavior on trunk.

Steps:
1. Set browser.tabs.closeWindowWithLastTab to false
2. Close all tabs except the last one
3. Middle click the tab
(In reply to Henrik Skupin (:whimboo) from comment #0)
> This behavior is only visible on 1.9.2 and 1.9.1. I cannot reproduce it on trunk.

closing...
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.