Master password is always asked at startup

RESOLVED DUPLICATE of bug 523910

Status

RESOLVED DUPLICATE of bug 523910
9 years ago
8 years ago

People

(Reporter: glandium, Unassigned)

Tracking

(Blocks: 1 bug)

SeaMonkey 2.0 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Even though the master password settings say the master password is going to be prompted the first time it will be *used*, it is systematically prompted at startup, which is rather annoying. This doesn't happen in Firefox, so I guess this is seamonkey doing something requiring the master password at startup.

Comment 1

9 years ago
I also believe this to be a bug.  I have my master password option set to "The first time it is needed", yet it prompts me *every* time the browser is opened, on or offline.  My home page is blank, so there is absolutely no need for this password prompt.  I believe when they fixed another bug regarding multiple prompts in e-mail for the 2.0 release (I don't know the ID off hand, sorry), this bug resulted from it.  Please fix this issue so that the "Master Password Timeout" options work again, as this bug is VERY annoying, enough for me to look elsewhere for a browser for the first time since this was v0.96 many years ago!

Comment 2

9 years ago
It is not logical to require MP at startup for the browser.  The cases for password protection are:  login to a site, use mail/news with saved passwords, or modify browser settings related to security (such as, look at the saved password list).  Unless one of these features is used, there is no need to request the MP.  When one of these features is used, the MP dialog should appear.  Please change this "feature" -- I don't know if this functionality is "by design," but it's poor design and degrades usability.  It's especially bad in the sense that the name of the login dialog ("Please enter the password for the software security device") makes absolutely no sense in the context.  I saw this dialog when starting Thunderbird and had to track down its origin, as there's no indication that it was Tbird that was presenting it!  Thanks.

Comment 3

9 years ago
I observe the same, but have an additional problem. When I click on a link in a mail (in Microsoft Outlook, sorry *shame*) and SeaMonkey is started for the first time, the following happens:
1. I get an error window stating:
General error: 
It regarded URL: http://www.someurl.org/. The system cannot find the specified file.
2. The window for the master password is opened behind all other windows.
3. When I enter the password the requested page is opened anyhow.

FWIW: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100104 SeaMonkey/2.0.2

Comment 4

9 years ago
Same problem!! It's annoying!!
Blocks: 570421

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 523910
You need to log in before you can comment on or make changes to this bug.