Talos shutdown crash during Ts_cold test [@ nsAppShell::ProcessNextNativeEvent(int)] involving libgtk

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: mak, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
crash, intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3.6 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bug in GTK+], crash signature)

(Reporter)

Description

8 years ago
the stack is similar to other failures but not identical, hard to say if it's a dupe

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258205813.1258206771.21554.gz

Thread 0 (crashed)
 0  libgtk-x11-2.0.so.0.1200.0 + 0x231c8b
    eip = 0xb6e88c8b   esp = 0xbf8bc910   ebp = 0xbf8bc988   ebx = 0xb6fd80bc
    esi = 0xafcb6d00   edi = 0xafa72390   eax = 0xb5f57820   ecx = 0xafcb6d00
    edx = 0x00650073   efl = 0x00010202
    Found by: given as instruction pointer in context
 1  libgtk-x11-2.0.so.0.1200.0 + 0x231f90
    eip = 0xb6e88f91   esp = 0xbf8bc990   ebp = 0xbf8bc9a8
    Found by: previous frame's frame pointer
 2  libgdk-x11-2.0.so.0.1200.0 + 0x175e7
    eip = 0xb6bcc5e8   esp = 0xbf8bc9b0   ebp = 0xbf8bc9c8
    Found by: previous frame's frame pointer
 3  libglib-2.0.so.0.1400.1 + 0x2f8d5
    eip = 0xb6a128d6   esp = 0xbf8bc9d0   ebp = 0xbf8bc9f8
    Found by: previous frame's frame pointer
 4  libglib-2.0.so.0.1400.1 + 0x2f11b
    eip = 0xb6a1211c   esp = 0xbf8bca00   ebp = 0xbf8bca58
    Found by: previous frame's frame pointer
 5  libglib-2.0.so.0.1400.1 + 0x3255e
    eip = 0xb6a1555f   esp = 0xbf8bca60   ebp = 0xbf8bcab8
    Found by: previous frame's frame pointer
 6  libglib-2.0.so.0.1400.1 + 0x32ac4
    eip = 0xb6a15ac5   esp = 0xbf8bcac0   ebp = 0xbf8bcad8
    Found by: previous frame's frame pointer
 7  libxul.so!nsAppShell::ProcessNextNativeEvent(int) [nsAppShell.cpp:01adc20ea792 : 147 + 0x9]
    eip = 0xb7b09ee0   esp = 0xbf8bcae0   ebp = 0xbf8bcaf8
    Found by: previous frame's frame pointer
 8  libxul.so!nsBaseAppShell::DoProcessNextNativeEvent(int) [nsBaseAppShell.cpp:01adc20ea792 : 151 + 0xa]
    eip = 0xb7b1e668   esp = 0xbf8bcb00   ebp = 0xbf8bcb18
    Found by: previous frame's frame pointer
 9  libxul.so!nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal*, int, unsigned int) [nsBaseAppShell.cpp:01adc20ea792 : 284 + 0x9]
    eip = 0xb7b1e89d   esp = 0xbf8bcb20   ebp = 0xbf8bcb48
    Found by: previous frame's frame pointer
10  libxul.so!nsThread::ProcessNextEvent(int, int*) [nsThread.cpp:01adc20ea792 : 508 + 0x1c]
    eip = 0xb7be6b2a   esp = 0xbf8bcb50   ebp = 0xbf8bcb88
    Found by: previous frame's frame pointer
11  libxul.so!NS_ProcessPendingEvents_P(nsIThread*, unsigned int) [nsThreadUtils.cpp : 200 + 0x11]
    eip = 0xb7bb742a   esp = 0xbf8bcb90   ebp = 0xbf8bcbc8
    Found by: previous frame's frame pointer
12  libxul.so!mozilla::ShutdownXPCOM(nsIServiceManager*) [nsXPComInit.cpp:01adc20ea792 : 692 + 0xb]
    eip = 0xb7bba4a0   esp = 0xbf8bcbd0   ebp = 0xbf8bcc18
    Found by: previous frame's frame pointer
13  libxul.so!ScopedXPCOMStartup::~ScopedXPCOMStartup() [nsAppRunner.cpp:01adc20ea792 : 1017 + 0x7]
    eip = 0xb7320f9e   esp = 0xbf8bcc20   ebp = 0xbf8bcc48
    Found by: previous frame's frame pointer
14  libxul.so!XRE_main [nsAppRunner.cpp:01adc20ea792 : 3534 + 0xb]
    eip = 0xb73233e6   esp = 0xbf8bcc50   ebp = 0xbf8bd1d8
    Found by: previous frame's frame pointer
15  firefox-bin!main [nsBrowserApp.cpp:01adc20ea792 : 158 + 0xc]
    eip = 0x080495c7   esp = 0xbf8bd1e0   ebp = 0xbf8bd238
    Found by: previous frame's frame pointer
16  libc-2.6.1.so + 0x1604f
    eip = 0xb669a050   esp = 0xbf8bd240   ebp = 0xbf8bd2a8
    Found by: previous frame's frame pointer
17  ld-2.6.1.so + 0xcdf
    eip = 0xb7fa0ce0   esp = 0xbf8bd244   ebp = 0xbf8bd2a8
    Found by: stack scanning
18  libc-2.6.1.so + 0x1604f
    eip = 0xb669a050   esp = 0xbf8bd250   ebp = 0xbf8bd2a8
    Found by: stack scanning
19  ld-2.6.1.so + 0x181f
    eip = 0xb7fa1820   esp = 0xbf8bd260   ebp = 0xbf8bd2a8
    Found by: stack scanning
20  libc-2.6.1.so + 0xff3
    eip = 0xb67c9ff4   esp = 0xbf8bd274   ebp = 0xbf8bd2a8
    Found by: stack scanning
21  ld-2.6.1.so + 0xcdf
    eip = 0xb7fa0ce0   esp = 0xbf8bd278   ebp = 0xbf8bd2a8
    Found by: stack scanning
22  ld-2.6.1.so + 0x1265f
    eip = 0xb7f98660   esp = 0xbf8bd298   ebp = 0xbf8bd2a8
    Found by: stack scanning
23  libc-2.6.1.so + 0x15f7c
    eip = 0xb6699f7d   esp = 0xbf8bd29c   ebp = 0xbf8bd2a8
    Found by: stack scanning
24  ld-2.6.1.so + 0xff3
    eip = 0xb7fa0ff4   esp = 0xbf8bd2a0   ebp = 0xbf8bd2a8
    Found by: stack scanning
(Reporter)

Updated

8 years ago
Severity: normal → critical
Whiteboard: [orange]
(Reporter)

Updated

8 years ago
Summary: Talos crash during Ts_cold test [@nsAppShell::ProcessNextNativeEvent(int)] → Talos crash during Ts_cold test [@nsAppShell::ProcessNextNativeEvent(int)] involving libgtk
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258430078.1258432913.19239.gz
Linux mozilla-central talos dirty on 2009/11/16 19:54:38  

Thread 0 (crashed)
 0  libgtk-x11-2.0.so.0.1200.0 + 0x231c8b
    eip = 0xb6e19c8b   esp = 0xbfbec7e0   ebp = 0xbfbec858   ebx = 0xb6f690bc
    esi = 0xafb84c40   edi = 0xafa90470   eax = 0xb5f57820   ecx = 0xafb84c40
    edx = 0x00650073   efl = 0x00010202
    Found by: given as instruction pointer in context
 1  libgtk-x11-2.0.so.0.1200.0 + 0x231f90
    eip = 0xb6e19f91   esp = 0xbfbec860   ebp = 0xbfbec878
    Found by: previous frame's frame pointer
 2  libgdk-x11-2.0.so.0.1200.0 + 0x175e7
    eip = 0xb6b5d5e8   esp = 0xbfbec880   ebp = 0xbfbec898
    Found by: previous frame's frame pointer
 3  libglib-2.0.so.0.1400.1 + 0x2f8d5
    eip = 0xb69a38d6   esp = 0xbfbec8a0   ebp = 0xbfbec8c8
    Found by: previous frame's frame pointer
 4  libglib-2.0.so.0.1400.1 + 0x2f11b
    eip = 0xb69a311c   esp = 0xbfbec8d0   ebp = 0xbfbec928
    Found by: previous frame's frame pointer
 5  libglib-2.0.so.0.1400.1 + 0x3255e
    eip = 0xb69a655f   esp = 0xbfbec930   ebp = 0xbfbec988
    Found by: previous frame's frame pointer
 6  libglib-2.0.so.0.1400.1 + 0x32ac4
    eip = 0xb69a6ac5   esp = 0xbfbec990   ebp = 0xbfbec9a8
    Found by: previous frame's frame pointer
 7  libxul.so!nsAppShell::ProcessNextNativeEvent(int) [nsAppShell.cpp:a0c008161bd3 : 147 + 0x9]
    eip = 0xb7a9ae90   esp = 0xbfbec9b0   ebp = 0xbfbec9c8
    Found by: previous frame's frame pointer
 8  libxul.so!nsBaseAppShell::DoProcessNextNativeEvent(int) [nsBaseAppShell.cpp:a0c008161bd3 : 151 + 0xa]
    eip = 0xb7aaf618   esp = 0xbfbec9d0   ebp = 0xbfbec9e8
    Found by: previous frame's frame pointer
 9  libxul.so!nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal*, int, unsigned int) [nsBaseAppShell.cpp:a0c008161bd3 : 278 + 0x9]
    eip = 0xb7aaf821   esp = 0xbfbec9f0   ebp = 0xbfbeca18
    Found by: previous frame's frame pointer
10  libxul.so!nsThread::ProcessNextEvent(int, int*) [nsThread.cpp:a0c008161bd3 : 508 + 0x1c]
    eip = 0xb7b77e3a   esp = 0xbfbeca20   ebp = 0xbfbeca58
    Found by: previous frame's frame pointer
...

FAIL: Busted: ts_cold_generated_max
FAIL: crash during run (stack found)

Updated

8 years ago
Duplicate of this bug: 529391

Comment 3

8 years ago
Linux mozilla-central talos dirty [testfailed] Started 14:21, finished 15:08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258496491.1258499248.28872.gz

Comment 4

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1258501908.1258505102.31781.gz

Linux mozilla-1.9.2 talos dirty [testfailed] Started 15:51, finished 16:46

Comment 5

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258502529.1258505227.722.gz
Linux mozilla-1.9.2 test everythingelse [testfailed] Started 15:28, finished 16:49
Blocks: 438871
(Reporter)

Comment 6

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258538997.1258542358.31445.gz
Linux mozilla-central talos dirty on 2009/11/18 02:09:57
Blocks: 519438
From comment 0:

 0  gtk_tooltip_show_tooltip
    /build/buildd/gtk+2.0-2.12.0/gtk/gtktooltip.c:854
 1  tooltip_popup_timeout
    /build/buildd/gtk+2.0-2.12.0/gtk/gtktooltip.c:974
 2  gdk_threads_dispatch
    /build/buildd/gtk+2.0-2.12.0/gdk/gdk.c:470
 3  g_timeout_dispatch
    /build/buildd/glib2.0-2.14.1/glib/gmain.c:3488
 4  g_main_dispatch
    /build/buildd/glib2.0-2.14.1/glib/gmain.c:2061
    IA__g_main_context_dispatch
    /build/buildd/glib2.0-2.14.1/glib/gmain.c:2613
 5  g_main_context_iterate
    /build/buildd/glib2.0-2.14.1/glib/gmain.c:2694
 6  IA__g_main_context_iteration
    /build/buildd/glib2.0-2.14.1/glib/gmain.c:2753
Summary: Talos crash during Ts_cold test [@nsAppShell::ProcessNextNativeEvent(int)] involving libgtk → Talos shutdown crash during Ts_cold test [@nsAppShell::ProcessNextNativeEvent(int)] involving libgtk
Overview of Changes from GTK+ 2.12.3 to 2.12.5
==============================================
* Bugs fixed:
496546 Tooltips may crashe because a window is destroyed
Duplicate of this bug: 519438
(Reporter)

Comment 12

8 years ago
(In reply to comment #9)
> Overview of Changes from GTK+ 2.12.3 to 2.12.5
> ==============================================
> * Bugs fixed:
> 496546 Tooltips may crashe because a window is destroyed

so this should be assigned to someone from IT to update GTK on the talos boxes, right?
(Reporter)

Updated

8 years ago
Depends on: 529786
(Reporter)

Comment 13

8 years ago
i have filed Bug 529786 against Server ops to ask the library upgrade.
Great work, Karl!
No longer blocks: 519438
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258645039.1258648231.20079.gz
Linux mozilla-central talos dirty on 2009/11/19 07:37:19  

Crash reason:  SIGSEGV
Crash address: 0xb6ebcc8b

Thread 0 (crashed)
 0  libgtk-x11-2.0.so.0.1200.0 + 0x231c8b
    eip = 0xb6ebcc8b   esp = 0xbff37f90   ebp = 0xbff38008   ebx = 0xb700c0bc
    esi = 0xafcad100   edi = 0xafbad470   eax = 0xb5f57820   ecx = 0xafcad100
    edx = 0x0000001a   efl = 0x00010202
    Found by: given as instruction pointer in context
 1  libgtk-x11-2.0.so.0.1200.0 + 0x231f90
    eip = 0xb6ebcf91   esp = 0xbff38010   ebp = 0xbff38028
    Found by: previous frame's frame pointer
 2  libgdk-x11-2.0.so.0.1200.0 + 0x175e7
    eip = 0xb6c005e8   esp = 0xbff38030   ebp = 0xbff38048
    Found by: previous frame's frame pointer
 3  libglib-2.0.so.0.1400.1 + 0x2f8d5
    eip = 0xb6a468d6   esp = 0xbff38050   ebp = 0xbff38078
    Found by: previous frame's frame pointer
 4  libglib-2.0.so.0.1400.1 + 0x2f11b
    eip = 0xb6a4611c   esp = 0xbff38080   ebp = 0xbff380d8
    Found by: previous frame's frame pointer
 5  libglib-2.0.so.0.1400.1 + 0x3255e
    eip = 0xb6a4955f   esp = 0xbff380e0   ebp = 0xbff38138
    Found by: previous frame's frame pointer
 6  libglib-2.0.so.0.1400.1 + 0x32ac4
    eip = 0xb6a49ac5   esp = 0xbff38140   ebp = 0xbff38158
    Found by: previous frame's frame pointer
 7  libxul.so!nsAppShell::ProcessNextNativeEvent(int) [nsAppShell.cpp:7d8cf8b7c3f9 : 147 + 0x9]
    eip = 0xb7b455d0   esp = 0xbff38160   ebp = 0xbff38178
    Found by: previous frame's frame pointer
 8  libxul.so!nsBaseAppShell::DoProcessNextNativeEvent(int) [nsBaseAppShell.cpp:7d8cf8b7c3f9 : 151 + 0xa]
    eip = 0xb7b59d58   esp = 0xbff38180   ebp = 0xbff38198
    Found by: previous frame's frame pointer
 9  libxul.so!nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal*, int, unsigned int) [nsBaseAppShell.cpp:7d8cf8b7c3f9 : 284 + 0x9]
    eip = 0xb7b59f8d   esp = 0xbff381a0   ebp = 0xbff381c8
    Found by: previous frame's frame pointer
10  libxul.so!nsThread::ProcessNextEvent(int, int*) [nsThread.cpp:7d8cf8b7c3f9 : 508 + 0x1c]
    eip = 0xb7c21c5e   esp = 0xbff381d0   ebp = 0xbff38208
    Found by: previous frame's frame pointer
11  libxul.so!NS_ProcessPendingEvents_P(nsIThread*, unsigned int) [nsThreadUtils.cpp : 200 + 0x11]
    eip = 0xb7bf2226   esp = 0xbff38210   ebp = 0xbff38248
    Found by: previous frame's frame pointer
12  libxul.so!mozilla::ShutdownXPCOM(nsIServiceManager*) [nsXPComInit.cpp:7d8cf8b7c3f9 : 692 + 0xb]
    eip = 0xb7bf528c   esp = 0xbff38250   ebp = 0xbff38298
    Found by: previous frame's frame pointer
13  libxul.so!ScopedXPCOMStartup::~ScopedXPCOMStartup() [nsAppRunner.cpp:7d8cf8b7c3f9 : 1017 + 0x7]
    eip = 0xb735745e   esp = 0xbff382a0   ebp = 0xbff382c8
    Found by: previous frame's frame pointer
14  libxul.so!XRE_main [nsAppRunner.cpp:7d8cf8b7c3f9 : 3534 + 0xb]
    eip = 0xb73598a6   esp = 0xbff382d0   ebp = 0xbff38858
    Found by: previous frame's frame pointer
15  firefox-bin!main [nsBrowserApp.cpp:7d8cf8b7c3f9 : 158 + 0xc]
    eip = 0x080495c7   esp = 0xbff38860   ebp = 0xbff388b8
    Found by: previous frame's frame pointer


Failed ts_cold_generated_med: 
		Stopped Thu, 19 Nov 2009 08:00:40
FAIL: Busted: ts_cold_generated_med
FAIL: crash during run (stack found)
The bug that was duped to this one was a blocker; should this be? Do we expect this to be fixed by 496019?
Flags: blocking-firefox3.6?
(Reporter)

Comment 17

8 years ago
was a blocker because had half-unknown causes, thanks to karl we know this i most likely due to a libgtk library version that is a bit outdated (well, it's part of ubuntu 7 that is used on our talos boxes), newer versions of that lib have a crash fix (See comment 9).
bug 529786 is filed to update libraries on those boxes, if you think we should also investigate a code fix to workaround the crash, we probably need a platform bug for that. hard to say how many users could be on that version of the library and how often they could see the crash (it's intermittent on talos boxes too)
w00t - not blocking
Flags: blocking-firefox3.6? → blocking-firefox3.6-
I agree not blocking.  Ubuntu 7.10 gutsy is not supported now.
crash-stats has the odd crash that looks like it could be the same on a different distro (with different symbol offsets).

But I doubt we can do anything reasonable to work around on our side.
Turn off tooltips, or never release windows are the only options AFAIK.
(In reply to comment #19)
> But I doubt we can do anything reasonable to work around on our side.
> Turn off tooltips, or never release windows are the only options AFAIK.
What about a configure check at least to make sure we are on a newer version?
(In reply to comment #20)
> What about a configure check at least to make sure we are on a newer version?

It doesn't matter what version we build with.
At run-time, 2.12.0 - 2.12.3 and maybe .4 had the bug. 2.10.x did not.
I don't think we want a run-time check.

It is about time we considered increasing our run-time requirements, but that's a bigger issue really.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258670771.1258675815.14113.gz
Linux mozilla-central talos dirty on 2009/11/19 14:46:11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258790753.1258793986.20143.gz
Linux mozilla-central talos dirty on 2009/11/21 00:05:53  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258793927.1258796627.15939.gz
Linux mozilla-central talos dirty on 2009/11/21 00:58:47  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258811119.1258816005.10975.gz
Linux mozilla-central talos dirty on 2009/11/21 05:45:19

Updated

8 years ago
Summary: Talos shutdown crash during Ts_cold test [@nsAppShell::ProcessNextNativeEvent(int)] involving libgtk → Talos shutdown crash during Ts_cold test [@ nsAppShell::ProcessNextNativeEvent(int)] involving libgtk
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258891027.1258894023.6594.gz
Linux mozilla-central talos dirty on 2009/11/22 03:57:07  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258894738.1258897898.20575.gz
Linux mozilla-central talos dirty on 2009/11/22 04:58:58  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1258903043.1258905927.18226.gz
Linux mozilla-central talos dirty on 2009/11/22 07:17:23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259049474.1259052399.18236.gz
Linux mozilla-central talos dirty on 2009/11/23 23:57:54  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259073046.1259076012.4278.gz
Linux mozilla-central talos dirty on 2009/11/24 06:30:46
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259115238.1259118372.3105.gz
Linux mozilla-central talos dirty on 2009/11/24 18:13:58  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259116840.1259119775.18680.gz
Linux mozilla-central talos dirty on 2009/11/24 18:40:40

Comment 50

8 years ago
dbaron / ted: please excuse my ignorance, why haven't we collected system symbols for our talos boxes and sent them to the crash reporter?
The talos machines process their crashes locally, so it'd be slightly more complicated than that. I filed bug 528231 on it.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259188175.1259191347.30035.gz
Linux mozilla-central talos dirty on 2009/11/25 14:29:35  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259199188.1259202293.22680.gz
Linux mozilla-central talos dirty on 2009/11/25 17:33:08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259227183.1259230301.6808.gz
Linux mozilla-central talos dirty on 2009/11/26 01:19:43
Whiteboard: [orange] → [orange][bug in GTK+]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259602797.1259603878.18848.gz&fulltext=1
Linux mozilla-central talos tp4 on 2009/11/30 09:39:57
Linux mozilla-central talos dirty [testfailed] Started 14:24, finished 15:09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259879048.1259881723.31189.gz&fulltext=1
Looks like this went from a seemingly random crash to a permanent crash when I landed the fix for bug 520639 last night. I doubt the patch in that bug caused any crashes, and we're now seemingly reliably crashing with this signature, when doing talos dirty runs.

Is there a plan to upgrade this tinderbox to get to a more stable os etc, or is there something else we can do about this?
jst: see the blocking bug 529786.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1259950167.1259953144.25636.gz
Linux mozilla-central talos dirty on 2009/12/04 10:09:27  

(twice in the same test run!)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1260524556.1260527404.15625.gz
Linux mozilla-central talos dirty on 2009/12/11 01:42:36  
FAIL: Busted: ts_cold_generated_max

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1260534710.1260538047.9675.gz
Linux mozilla-central talos dirty on 2009/12/11 04:31:50  
FAIL: Busted: ts_cold_generated_med
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1260552245.1260555325.14127.gz
Linux mozilla-central talos dirty on 2009/12/11 09:24:05  
FAIL: Busted: ts_cold_generated_med
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1260649533.1260652704.32742.gz
Linux mozilla-central talos dirty on 2009/12/12 12:25:33  
FAIL: Busted: ts_cold_generated_max
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1260648677.1260651988.24881.gz
Linux mozilla-central talos dirty on 2009/12/12 12:11:17  
FAIL: Busted: ts_cold_generated_max

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1260652916.1260656188.6713.gz
Linux mozilla-central talos dirty on 2009/12/12 13:21:56  
FAIL: Busted: ts_cold_generated_med

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1260654413.1260657319.19178.gz
Linux mozilla-central talos dirty on 2009/12/12 13:46:53  
FAIL: Busted: ts_cold_generated_max

Comment 102

8 years ago
Obviously this crash is now almost permanent, as opposed to previously being pretty random. Do we know when/why that happened? (And can we stop pasting the buildbot log for each orange?)
In comment 70 jst mentions bug 520639, but I haven't been paying much attention.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261745649.1261748524.7588.gz
FAIL: Busted: ts_cold_generated_max

My guess is that this crash became much more common because we're doing a much larger number of startups/shutdowns in our tests since we added all the Ts variants.
This crash

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262885157.1262886195.1844.gz

sure looks like the same symptom as this bug, but occurred on

Linux mozilla-central talos tp4 on 2010/01/07 09:25:57

(Note: not "talos dirty", but "talos tp4".)
(In reply to comment #113)
> This crash
> 
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262885157.1262886195.1844.gz
> 
> sure looks like the same symptom as this bug, but occurred on
> 
> Linux mozilla-central talos tp4 on 2010/01/07 09:25:57
> 
> (Note: not "talos dirty", but "talos tp4".)

The actual crash looks the same, but this log doesn't show all the Gdk and GLib-GObject assertions and warnings that normally precede the crash in other logs here. I don't know if that's a significant difference in the overall scenario, though.
Linux mozilla-central talos dirty on 2010/01/08 12:28:25

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262982505.1262985828.26356.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1263394376.1263397579.25015.gz
Linux mozilla-central talos dirty on 2010/01/13 06:52:56
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264614478.1264614985.4524.gz
Linux mozilla-central talos nochrome on 2010/01/27 09:47:58  
FAIL: Busted: tdhtml
FAIL: crash during run (stack found)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264818923.1264821495.3106.gz
Linux mozilla-central talos dirty on 2010/01/29 18:35:23

Comment 135

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265635253.1265638157.9879.gz
Linux mozilla-central talos dirty on 2010/02/08 05:20:53

Comment 136

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265642909.1265645059.28071.gz
Linux mozilla-central opt test mochitest-other on 2010/02/08 07:28:29

Comment 137

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265642597.1265645798.4535.gz
Linux mozilla-central talos dirty on 2010/02/08 07:23:17

Comment 138

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265649358.1265652351.19839.gz
Linux mozilla-central talos dirty on 2010/02/08 09:15:58

Comment 139

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265651351.1265653697.3244.gz
Linux mozilla-central talos dirty on 2010/02/08 09:49:11

Comment 140

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265661087.1265663962.25696.gz
Linux mozilla-central debug test mochitest-other on 2010/02/08 12:31:27

Comment 141

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265664023.1265665501.11068.gz
Linux mozilla-central opt test mochitest-other on 2010/02/08 13:20:23

Comment 142

8 years ago
Please ignore the last two logs (comments 140 and 141.)
This doesn't show up on the rev3 Talos minis, so let's close it out.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 147

8 years ago
I saw a similar crash in bug 563399.
See Also: → bug 563399

Comment 148

8 years ago
Another similar crash: bug 542928 comment 215.
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsAppShell::ProcessNextNativeEvent(int)]
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange][bug in GTK+] → [bug in GTK+]
You need to log in before you can comment on or make changes to this bug.