Firefox Stored passwords feature won't handle page redirects during page login procedure

RESOLVED DUPLICATE of bug 355063

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 355063
8 years ago
7 years ago

People

(Reporter: Adrian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-06-04], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Hi,

I have a Hotmail account and would like to use the saved login details feature in Firefox. When I try logging into this website it redirects to https://login.live.com for the username and password. Is there a way of handling the redirects so that when I try accessing www.hotmail.com the login and password details are entered into login.live.com. I think it's worth looking at this issue on the basis that the user needs to know that the login page has been redirected and is aware of the new website's address, with the option to turn off the warning message and be able to use stored passwords.

Thanks,

Adrian

Reproducible: Always

Steps to Reproduce:
1. access www.hotmail.com
2. page address gets updated to login.live.com
3. Firefox stored passwords don't work
Actual Results:  
Firefox doesn't warn me that the login page has been changed and can't fill in the login and password details

Expected Results:  
Firefox handles page redirect to login.live.com
fills in login and password
(Reporter)

Comment 1

8 years ago
If you type in the address login.live.com your page gets redirected to
https://login.live.com/login.srf?bk=83910401. The following time I tried accessing login.live.com and got redirected to https://login.live.com/login.srf?bk=84040549. A suitable warning message could be "Your login website has been redirected and Firefox stored passwords have been disabled" with two options "enable stored passwords" and "don't show this warning again".
Are you saying you already have a stored Hotmail password in Firefox (and presumably the login page has changed recently?), or that live.com logins are not remembered?

Trying to login on that page with a fake username/password doesn't trigger Firefox's password saving because autocomplete=off is set in the page. Probably the same issue with using a real login.
Component: Security → Password Manager
Product: Firefox → Toolkit
QA Contact: firefox → password.manager

Comment 3

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a4) Gecko/20100407 MozillaDeveloperPreview/3.7a4
Yes, Live.com logins are not remembered. Able to store the password in the password manager for live.com logins but firefox  is not prompting the password for the next login.
Whiteboard: [closeme 2010-06-04]

Comment 4

7 years ago
login.live.com uses script to generate its form so I'm duping this ageist bug 355063.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355063
You need to log in before you can comment on or make changes to this bug.