Closed Bug 528855 Opened 10 years ago Closed 8 years ago

Weave preferences dialog has bright red bar saying "Unknown Error", if I cancel Master Password dialog.

Categories

(Firefox :: Sync, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 543784
Future

People

(Reporter: dholbert, Unassigned)

Details

Attachments

(1 file)

STR:
 1. Add a master password to your Firefox profile
 2. Install Weave.
 3. Restart Firefox.  Cancel any Master Password dialogs that appear.
 4. Click the Weave status-bar icon, and choose "Preferences"
 5. Press "Connect" button
   --> Master Password dialog appears
 6. Click "Cancel"

ACTUAL RESULTS:
 Bright red bar appears in the prefs dialog, below my username, saying "Unknown Error".

EXPECTED RESULTS:
 A more informative error message in that bar, or no error bar at all.

Screenshot coming up.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091114 Minefield/3.7a1pre
Weave 1.0b1
Here's a screenshot of the "actual results" here.

I guess my objection here is that it looks a lot scarier than it needs to.

Note that the same message also appears in a sumbenu off of Weave's status-bar notification area.  That makes more sense to me.
Severity: normal → minor
Target Milestone: --- → Future
Pretty sure we ask for the Master Password now in all the right places and handle rejection accordingly.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543784
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.