Closed Bug 528886 Opened 10 years ago Closed Last year

Firefox and Fennec should support geographically augmented reality as a web application

Categories

(Core :: DOM: Device Interfaces, enhancement)

enhancement
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: mithgol, Unassigned)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

"Geographically augmented reality" is created when an application takes the video camera input (which is the reality), then augments (overlays) it with some layers of markers and descriptions taken from GIS database(s). The application takes the position and rotation and tilt and azimuth of the camera into account when it renders the geolayers over video.

An example of such an application is Layar Reality Browser, see http://layar.com/

However, almost the same set of functions could be made uniformly available, inside the browser, for any Web site (Web application) that needs them.

Geographically augmented reality = geolocation + accelerometer + digital compass + camera input (+ Internet access to the geodatabase).

Geolocation support is readily available.

Accelerometer support is here since bug 485943.

Camera input is probably something that bug 451674 and bug 507749 would provide when fixed. Note that geographically augmented reality does not need to capture frames or video streams from the camera (though other types of augmented reality probably do, when they use visual keys and glues in order to attach descriptions and elements to them): geographically augmented reality just needs to display the raw video input on the page (like <video>, but local) and to be able to draw on top of it (i.e. place elements of higher z-index above the <camera>).

And I see (right now) no bugs dedicated to support of digital compass. It's probably time now to add the digital compass to DOM, because it was told at http://gigaom.com/2009/10/19/on-mobile-phones-firefoxs-big-bet-is-nokia-android/ that Firefox or Fennec is going to be ported to Android devices (some of which have digital compasses).

Reproducible: Always




This feature request has a metabug nature.
Some examples of free Android applications of geographically augmented reality that could as well be websites:

Google Sky Map: http://www.android.com/market/free.html#app=skymap

Wikitude - Mobile Global Travel Guide: http://www.android.com/market/free.html#app=wikitude
Status: UNCONFIRMED → NEW
Ever confirmed: true
No longer depends on: 451674
Depends on: camera
This is now at least possible via standardized APIs, and is not really valid as a browser bug anymore.
Status: NEW → RESOLVED
Closed: Last year
Component: DOM: Core & HTML → DOM: Device Interfaces
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.