No "click here to get the plugin" for embed height<35

VERIFIED INVALID

Status

()

Core
Plug-ins
P3
normal
VERIFIED INVALID
18 years ago
16 years ago

People

(Reporter: Jesse Ruderman, Assigned: av (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
If I don't have the necessary plugin, an embed with width and height defined 
doesn't get a "click here to get the plugin" box when the height is less than 
35.  

I don't know what happens if I do have the plugin installed, andI haven't 
compared Mozilla to other browsers here, so this bug may be invalid.
(Reporter)

Comment 1

18 years ago
Created attachment 14846 [details]
width="300" height="35" (box)
(Reporter)

Comment 2

18 years ago
Created attachment 14847 [details]
width="300" height="34" (no box)
(Reporter)

Comment 3

18 years ago
Note that some space is reserved for the plugin in the second testcase, we just 
don't get a box.  I can't tell whether the empty space is clickable.
(Assignee)

Comment 4

18 years ago
It is clickable. I think this behaviour (good or bad) is no different from 4.x. 
We have nothing to do with small space devoted to the plugin. Theoretically, it 
can be 1 by 1 or even 0 by 0. The good thing though is that the pop up saying 
that you need a plugin shows up automatically without clicking when the given 
mime type has never been seen yet. To test this you may open the registry key 
HKEY_CURRENT_USER\Software\Netscape\Netscape Navigator\Default Plugin and remove 
the appropriate mime type from the list.

Marking invalid. If you have other considerations please feel free to reopen it.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

18 years ago
I'm not seeing a popup on either testcase using ns4x or mozilla.  Am I supposed 
to?  I'm also not getting anything when I click the box or the blank area.
(Assignee)

Comment 6

18 years ago
Yes, you are, when you click the box or blank area in the second test case. It 
should be either JavaScript or native dialog box depending on whether you have 
JavaScript enabled. I see them on my 4.x installation. Make sure you have 
npnul32.dll installed in the plugins folder.
(Reporter)

Comment 7

18 years ago
I don't see them on either browser, and I've tried with JS both on and off.
(Assignee)

Comment 8

18 years ago
Do you see Netscape Default Plug-in when you do about:plugins?
(Reporter)

Comment 9

18 years ago
ns4.75: yes, at the bottom there is a "Netscape Default Plug-in" entry.
mozilla: nothing happens when i press enter in the location bar.

(i'm confused about what the expected results for various things are in each 
browser.  is this supposed to work with mozilla as well?  am i supposed to see 
a pop-up in just ns4x or both browsers?)
(Reporter)

Comment 10

18 years ago
The URL http://home.netscape.com/plugins/ (link on ns4x's about:plugins) loads 
for Mozilla but not ns4.75.  Weird.
(Reporter)

Comment 11

18 years ago
Ignore my previous comment.  I have ads.web.aol.com set to 127.0.0.1 and I was 
too lazy to make my test web server give me an identifiable error page.
(Reporter)

Comment 12

18 years ago
Bug 48483 might be related... one commenter on that bug was having trouble with 
the default plugin on Windows as well.
(Reporter)

Comment 13

18 years ago
The problem of nothing happening (no pop-ups, nothing happening when I click on 
the box) keeps going away and coming back as I play with the feature.  I 
haven't quite figured what makes it go away and what makes it come back.  
Adding type="video/quicktime" (bug 44692) to the testcase with the box might 
have something to do with making the problem go away temporarily, but I can't 
figure out what makes it come back.  I'll file a new bug for this soon; in the 
meantime, please don't verify this as invalid.

If I delete the registry entry, the box becomes "click here after installing 
the plugin" instead of "click here to get the plugin" for the testcase that 
shows the box, and both testcases give me pop-ups.  But if I hit reload, the 
popup doesn't come back.  This is wacky becuase "cancel" should not be 
synonymous with "go away forever", and should get a separate bug.
(Reporter)

Comment 14

18 years ago
Restarting Mozilla also has something to do with making the problem go away and 
come back.
(Reporter)

Comment 15

18 years ago
I can't reproduce the problem with "cancel" being permanent, so it's probably 
just another unintended, intermittent part of this bug or related bug and not a 
misdesigned feature.
(Assignee)

Comment 16

18 years ago
I am kinda lost here. Could you please state exactly what the problem is i.e.: 
what is the observed behaviour and how it is different from what is expected and 
what are exact steps to reproduce it? I keep trying it myself and don't see 
anything contradictory, so this is either different factors which I don't have 
or just simple misunderstanding. If you have resources could you also try this 
on NT?
(Assignee)

Comment 17

18 years ago
Shrirang, looks like this is strictly Win98 specific, if you can devote a cycle 
at this time could please confirm and reopen if necessary?
(Assignee)

Comment 18

18 years ago
And will be great if you can compare Mozilla and 4.x in this respect.

Comment 19

18 years ago
sure, I will try this with a new build and comment.Thx

Comment 20

18 years ago
I have tried this. My results are:
I see no different behaviour between mozilla and 4.72 on windows wit hregards to 
both testcases. The frst one does show up the puzzle icon while the second one 
does not. If I remove the reg entry for the mime type (movie/quicktime) then I 
see the dialog pop up automatically.Also, the blank area in the second testcase 
is clickable. The plugin download dialog not popping up on seamonkey might be 
another bug, bug 44692. I am marking this verified since the original problem 
reported is invalid. David, pls open any new bugs for other problems tha toyu 
have mentioned in this bug report. Thanks !
Status: RESOLVED → VERIFIED
(Assignee)

Comment 21

18 years ago
Thanks, Shrirang. Just one question to make myself relaxed: did you try it on 
Win98?

Comment 22

18 years ago
Yes, Andrei, I verified this on windows NT and Win 98 (build 20000920m18). All 
seem to have the same behaviour (4.x, seamonkey on NT and 98)
(Reporter)

Comment 23

18 years ago
This still doesn't work for me on ns 4.75 or mozilla...
(Assignee)

Comment 24

18 years ago
Could you please provide with your OS build number?
(Reporter)

Comment 25

18 years ago
C:\Program Files\Netscape\Communicator\Program\netscape.exe
4.75.0.6

C:\Program Files\Netscape\Communicator\Program\Plugins\npnul32.dll
1, 0, 0, 14
45056 bytes

C:\Windows\Desktop\moz 091800\mozilla.exe
2000 091808 (Also happens with various other versions)

C:\Windows\Desktop\moz 091800\plugins\npnul32.dll
1, 0, 0, 15
33664 bytes


HKEY_CURRENT_USER\Software\Netscape\Netscape Navigator\Default Plugin\(Default)
(value not set)

Windows 98 4.10.2222 (from ver).

Behind a firewall.  I do have quicktime installed.
(Reporter)

Comment 26

18 years ago
When playing with this bug, I have the following on my desktop:
- Shortcut to a Mozilla build with -console
- Shortcut to installed Netscape 4.75
- Second attachment, saved
- Modified version of second attachment with type="video/quicktime"

I also have regedit open so I can kill the video/quicktime = none entry when it 
appears.  


When Mozilla doesn't bring up the popup, it doesn't do anything to the 
registry.  When it does, a key of video/quicktime = "(none)" shows up.

When the popup comes up, I see "Document http://cgi.netscape.com/cgi-
bin/plugins/get_plugin.cgi?mimetype=video/quicktime loaded successfully" in the 
console window.

I can't find a predictable pattern of when the popup comes up and when it 
doesn't, but it's not simply random -- there seem to be streaks of working and 
not working.  It comes up more often with the version of the testcase that has 
the mimetype defined, but still not always.  Restarting Mozilla often makes it 
jump from working to not working, but not aways.

I think the height=35 testcase behaves similiarly.  Netscape 4.75 also doesn't 
bring up the popup much of the time.

I'm mostly testing with Mozilla build 2000091808 because newer builds are 
crashing on exit, but I have noticed the popup not appearing on a newer build.

Comment 27

16 years ago
Created attachment 73300 [details]
A MIDI file used to create a non-404 embed src


On 2002030604, I see no box for either test case, but when I right-click in
the space where I expect the box to be, I get nothing.
Reason: The plug-in data now gives 404 because the original movie has
disappeared.

I'm working on a new test case that includes this MIDI file.
Loading a MIDI file from a Bugzilla attachment should be less likely
to link-rot than loading from some free web host, correct?

Comment 28

16 years ago
Created attachment 73306 [details]
New test case linking to attachment 73300 [details]

This test case uses the MIDI file from attachment 73300 [details].
It includes six EMBED elements, with heights 16, 32, 34, 35, 64, and 128
pixels.
It obsoletes the first two attachments, which use "attachment 404 [details]".
Make sure to turn off QuickTime and Crescendo when trying it out to make sure
the default plug-in is called.

When I click in the area where the box *would* be, it puts up the proper
dialog for the first click (and then ignores all subsequent clicks).
See bug 115396 for left-click vs. right-click behavior.

Recent nightly builds still misbehave as originally described.
I suggest reopening.
You need to log in before you can comment on or make changes to this bug.