Closed Bug 529179 Opened 10 years ago Closed 9 years ago

automatically deal with excess try repo heads

Categories

(Release Engineering :: General, defect, P3)

All
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 554656

People

(Reporter: bhearsum, Assigned: lsblakk)

References

Details

(Whiteboard: [try-server])

The try repository ends up with a ton of extra heads after awhile, which slows down the pushlog and possibly other parts of the repository. We need to deal with this in some automated way, be it stripping heads periodically or automatically recloning on a regular basis - something that doesn't require intervention.
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3
Whiteboard: [try-server]
Assignee: nobody → lsblakk
Depends on: 595275
Ok so back to dealing with this, there is now a script that IT can run either by a bug request or with a cron job, which they say they prefer not to do it that way, however by looking at  the past couple of months of try usage here:

https://build.mozilla.org/buildapi/reports/pushes?starttime=1283324400&endtime=1287730800

It looks like midnight on Sunday is a good time, pushes are often 0 and if we
were to make it automatically close the try tinderbox page so that pushes to
try were stopped with a hook while the cleanup happened then we could feasibly
make this entirely automated.
Trying to consolidate this discussion into one place, there is more relevant conversation in bug 554656.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 554656
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.