Closed Bug 529273 Opened 11 years ago Closed 11 years ago

js timer exception when updating jumplists

Categories

(Firefox :: General, defect, P3)

x86
Windows 7
defect

Tracking

()

RESOLVED FIXED
Firefox 4.0

People

(Reporter: jimm, Assigned: jimm)

References

Details

Attachments

(1 file)

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "name is null" {file: "file:///F:/Mozilla/fir
efox/BUILD-DBG/dist/bin/modules/WindowsJumpLists.jsm" line: 344}]' when calling
method: [nsITimerCallback::notify]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCR
IPT_ERROR_WITH_DETAILS)"  location: "<unknown>"  data: yes]
************************************************************

For the test case in bug 487700. I'm guessing I forgot to kill a timer.
OS: Windows NT → Windows 7
Priority: -- → P3
Target Milestone: --- → Firefox 3.7
Version: unspecified → Trunk
Attached patch fixSplinter Review
Attachment #417513 - Flags: review?(dao)
Comment on attachment 417513 [details] [diff] [review]
fix

name in some cases can be null, causing the timed set on the current list to fail.
Attachment #417513 - Flags: review?(dao) → review+
Summary: js timer exception on popups for jump list module → js timer exception when updating jumplists
http://hg.mozilla.org/mozilla-central/rev/3b2fec6aa462
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 533231
You need to log in before you can comment on or make changes to this bug.