Sidebar panels localization not displayed

VERIFIED WONTFIX

Status

()

defect
P3
major
VERIFIED WONTFIX
19 years ago
18 years ago

People

(Reporter: karl, Assigned: tao)

Tracking

({l12y})

Trunk
mozilla0.9.4
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

In the sidebar, all panels ('Bookmarks', 'Search' and 'What's Related') are 
displayed in English.

I have translated all strings, and when I choose 'Add' | 'Customize Sidebar', 
the 'Available Sidebars' lists the translated strings (e.g. 'Søk' instead 
of 'Search'), and the right pane displays the the panels in English. If I 
remove the English ones and add the translated ones, the panels in the sidebar 
are still in English. This should be fixed ASAP.
The default sidebar (SB_ panel is controlled by
bin\defaults\[langcode]\panels.rdf. You need to localize this file. New profile
will then use this as the default. However, once there is a panels.rdf in your
profile, you can customize it via SB UI but manually changing the one in
bin\defaults.


Assignee: rchen → huftis
 
Assignee: huftis → rchen
The file contains an *internal* DTD subset:

<!DOCTYPE RDF 
[
<!ENTITY search.category.music		"Music - Artist">
<!ENTITY search.category.shareware	"Shareware">
<!ENTITY search.category.shopping	"Shopping">
<!ENTITY search.category.technews	"Tech News">
<!ENTITY search.category.web		"Web">
]
>

And all the text uses entity references, e.g. &search.category.music;. Can't 
the DTD subset be moved to an external DTD file (just like all the others)? 
Then the sidebars would be localized whenever you change locale (since the 
default panels *always* uses entity references).
Please note that the internal DTD subset in 'search.rdf' should also be 
externalized. *All* localizable text should be put in one place, else I *think* 
it's difficult for the installation script in language packs to put them in the 
right place.
IS this still a problem in the latest nightlies?
> IS this still a problem in the latest nightlies?

I don't know; I haven't tried a build later than M18.
Changed QA contact to blee@netscape.com.  Bom-Shik, is this a known problem?
QA Contact: teruko → blee
Because panels.rdf is dynamically changing, it may not be a good idea to 
externalize the strings.

Reassigned to ben.
Assignee: rchen → ben
I'm surprised this hasn't been fixed yet. It's *so* easy to fix. Just replace 
the internal DTD subset in 'panels.rdf':

<!DOCTYPE RDF 
[
<!ENTITY sidebar.panel.whats-related "What's Related">
<!ENTITY sidebar.panel.search "Search">
<!ENTITY sidebar.panel.tinderbox "Tinderbox">
<!ENTITY sidebar.nc-panel.stocks "Stocks">
<!ENTITY sidebar.panel.client-bookmarks "Bookmarks">
]
>

with this line:

<!DOCTYPE RDF SYSTEM "chrome://communicator/locale/sidebar/local-panels.dtd">

and change the names of the entities, e.g. 'sidebar.panel.whats-related' 
to '&sidebar.search.label;'. I'm attaching a modified 'panels.rdf' which works 
perfectly (today's build). And yes, it evens works if you remove and add panels.

Of course, the other files this bug is about have to be fixed in a similar way.
Sorry, I can't attach the file. BugZilla claims that I'm providing no or a 
empty file. But as I said, it's really easy to fix this bug. Just replace the 
internal DTD with a link to the chrome DTD files (which already exists), and 
change the name of the entity references.
Marking as NEW per user comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I see I've made a small mistake in my earlier comment. '&sidebar.panel.whats-
related;' should be changed to '&sidebar.whats-related.label;' (or the name in 
the DTD changed), not '&sidebar.search.label;' (which is the search label).
Blocks: 34145
Adding appropriate keywords.
Keywords: l12y, nsbeta1
Blocks: 12394
adding intl keyword
Keywords: intl
Nominated by 118n.

Remind - For Sidebar Nav Triage.
removing intl from l12y bugs
Keywords: intl
Changing QA Contact to andreasb.
QA Contact: blee → andreasb
nav triage team:

Marking nsbeta1+
Keywords: nsbeta1nsbeta1+
this has been nsbeta1+ but doesn't have a milestone. Can you add one paul?
QA Contact: andreasb → jonrubin
nav triage team:

Reassigning to pchen, marking target milestone mozilla0.9.2
Assignee: ben → pchen
Target Milestone: --- → mozilla0.9.2
Whiteboard: 1 day, eta 6/8
Just attached fix, updating status whiteboard, need r= and sr=
Status: NEW → ASSIGNED
Whiteboard: 1 day, eta 6/8 → fix in hand, awaiting r and sr
Adding matt@netscape.com to cc list to see if I can get a r= from him.
r=matt
Ooops, forgot to add alecf to cc list for sr. Sorry about the spam
Whiteboard: fix in hand, awaiting r and sr → fix in hand, awaiting sr
sr=alecf
updating status whiteboard with "awaiting a="
Whiteboard: fix in hand, awaiting sr → fix in hand, awaiting a=
a=blizzard on behalf of drivers for the trunk
fix checked onto trunk, marking fixed
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Not clear how to verify this.  If I check the Sidebar in a build from before
06/18 on a non-English OS (WinMe-Ja in my case), I can choose and display
non-English panels.  However, the Recommended panels (Buddy List, What's
Related, Search, Bookmarks, History) show up in English in builds from before
06/18, as well as today's build (06-25-06).  If I install the JA language pack,
then I can see the Recommended panels in Japanese, even in the 6.1b-en build. 
Can someone provide a test case for the problem that was fixed on 06/18?  Thanks. 
Teruko and I looked into this by modifying local-panels.dtd with localized
Japanese strings and then converting to UTF-8.  We were able to see our
modifications when looking in the left and right panes of Customize Sidebar, but
the list was still in English when looking at the entries in Tabs.  

See rchen's comment from 2000-11-07:
------------------------------------

 ------- Additional Comments From rchen@netscape.com 2000-11-07 11:08 -------

 Because panels.rdf is dynamically changing, it may not be a good idea to 
 externalize the strings.
------------------------------------

Since the file is dynamic, any changes made to the file will be overwritten by
what's on the server.  Therefore changes need to be made server-side, not
client-side.

Reopening this bug.


Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reassigning to evelyn, who is responsible for server-side changes.
Assignee: pchen → evelyn
Status: REOPENED → NEW
cc jaime
cc roberts for while jaime is on vacation.
Vishy - Is this your team's bug, or Netscape.com's???
Adding lynnw to cc-list
It is true that panels.rdf file is dynamic and that any changes made to the file 
will be overwritten by what's on the server however, as described above the 
problem is experienced only with Buddy List, What's Related, Search, Bookmarks, 
and History tabs which are client side tabs and the server side rdf files does 
not contain any entity referring to those tabs. Therefore, changes need to be 
made on client-side, not on server-side.
pushing out. 0.9.2 is done. (querying for this string will get you the list of
the 0.9.2 bugs I moved to 0.9.3)
Target Milestone: mozilla0.9.2 → mozilla0.9.3
I am not sure. Evelyn - are you going to fix this bug? 
Question: in what operating system are you seeing this problem? If you are using 
a Swedish operating system, you will see the correct localized strings for the 
Swedish sidebar in the sidebar customization window's left-hand pane. If you are 
using an English operating system, you will see English displayed in the sidebar 
customization window's left-hand pane.
Assignee: evelyn → akman
As I explained in detail above this is not a server isde issue. Reassigning to 
the owner. 
Assignee: akman → huftis
After reading through this bug again, I see from the original description that 
the problem is client-side. If you are using a US browser, you will see English. 
You need to create a localized JAR file (most likely named se-SV.jar for 
Swedish). It's that simple.
Creating the language pack se-SV.jar will give you a browser with a Swedish UI. 
You'll also want to creat a region pack as well.
OK. Panels.rdf lives somewhere else, so editing the JAR files won't matter. But 
this is definitely controlled by the client side. If changes need to be made, 
the Mozilla sidebar owner will have to do it.
Linda (INTL Sidebar Goddess) - Looks like this guy isn't recieving his 'zilla email.
Need to modify local-panels.rdf

Netscape needs to do the same
Linda/Msanz - Should we get this one reassgined?
Assignee: huftis → tao
Re-assigning to tao for now and cc rchen. Tao, who would be the correct owner
for this?
The sidebar panels are profile-bound: they are to be modified by users in Browser
session and will not be affected by UI language or content switch. Sidebar 
channels are similar to bookmarks. It might not make sense to entitize the
localizable resources. I'd suggest we add localization notes as to which part of
this file should be localized. 

Whiteboard: fix in hand, awaiting a=
Target Milestone: mozilla0.9.3 → mozilla0.9.4
Keywords: nsBranch
OK, after some discussion, we believe that it is a bad idea to put the
UI strings and the associated urls in two different files. The UI strings should
be entitized and declared in the internal DOCTYPE section to help identify what
are localizable, though.
Status: NEW → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → WONTFIX
mass change, switching qa contact from jonrubin to ruixu.
QA Contact: jonrubin → ruixu
Verified. (As per Tao's comments, it is reasonable not to fix it)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.