Closed Bug 529533 Opened 11 years ago Closed 6 years ago

Some features of Yahoo webmail are missing when using Firefox 3.6b3 user agent string

Categories

(Web Compatibility :: Desktop, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: matafagafo, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3 (.NET CLR 3.5.30729)

In FF 3.6 b3 some Yahoo webmail (old style interface) don't are showed, one sample is the "Loading..."  message that appears every time You ask for open a email, in FF 3.5 it is there but with FF 3.6 the message is missing.

Reproducible: Always

Steps to Reproduce:
1.Open Yahoo webmail 
2.Ask for open a mail
3.See "Loading..." message is missing
Actual Results:  
Message is missing

Expected Results:  
Show the message
Version: unspecified → 3.6 Branch
Flags: blocking-firefox3.6?
Could just be browser detection problems?

Try setting general.useragent.extra.firefox to Firefox/3.5 (in about:config) and see if it works?

I can't block on this until I get a confirmation, but Yahoo! Mail not working is serious so I'll leave it as a nomination for now.

Juan: can we get some QA love?
Keywords: qawanted
You are right, I tried the "useragent" set to Firefox/3.5 and now all Yahoo! features are working. 
So it's not a FF problem.
--> Tech Evangelism
Assignee: nobody → english-us
Component: General → English US
Flags: blocking-firefox3.6?
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Version: 3.6 Branch → unspecified
Fernando: what happens when you set it to Firefox/3.6 (instead of Firefox/3.6b3)?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Summary: Some features of Yahoo webmail are missing → Some features of Yahoo webmail are missing when using Firefox 3.6b3 user agent string
I tried Firefox/3.6 and the features are messing too. They only work with Firefox/3.5
Sent email to Y! Mail product team to make sure they're aware.
Today I realized that the missing features are back, I'm using:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6 (.NET CLR 3.5.30729)

All functionalities are ok now.
I think this bug can be closed.
Was this an issue of Yahoo not allowing a beta version of Firefox (and thus it's likely to still exist with a UA string that includes something like "Firefox/3.7b1"), or was it something else?

I'm *very* hesitant to mark this FIXED when the only test has been done with a release version of Firefox 3.6.
No more an issue. Yahoo Mail has changed a couple of times since that release.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.