Invite Attendees dialog: icons are messed up in case of missing participation role

RESOLVED FIXED in 1.0b2

Status

Calendar
Dialogs
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Stefan Sitter, Assigned: Simon Vaillancourt)

Tracking

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

8 years ago
Created attachment 413320 [details]
sample ics file

Lightning 1.0pre (20091118) with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091119 Shredder/3.0.1pre

In case of an attendee without participation role the icons in the Invite Attendees dialog are messed up. This issue has been reported in the German forum <http://www.sunbird-kalender.de/forum/viewtopic.php?f=8&t=2853>.

Steps to reproduce:
1. Import the attached sample ics file
2. Edit the event and open the Invite Attendees dialog
3. Check list of attendees on the left

Actual result:
Icons are messed up for the fourth attendee, see attached screenshot.

Expected result:
Do not break display on missing participation role.
(Reporter)

Updated

8 years ago
Attachment #413320 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Comment 1

8 years ago
Created attachment 413321 [details]
screenshot
Flags: blocking-calendar1.0?
(Reporter)

Comment 2

8 years ago
Currently we always set the role icon regardless if role is set or if role is undefined. <http://mxr.mozilla.org/comm-central/source/calendar/base/content/dialogs/calendar-event-dialog-attendees.xml#371>

RFC 5545 states the following for Participation Role:

  > If not specified on a property that allows this parameter, the
  > default value is REQ-PARTICIPANT. Applications MUST treat x-name and
  > iana-token values they don't recognize the same way as they would the
  > REQ-PARTICIPANT value.

So the correct behavior would be to display the REQ-PARTICIPANT icon.

Comment 3

8 years ago
Hence, the right behavior should be to show the "REQ-PARTICIPANT" icon in the dialog when the event (that comes from another calendar application) doesn't have the role or has a bad role not included in specifications.

But should Lightning change the bad role stored in the calendar to the default one ("REQ-PARTICIPANT") only when the user opens the attendee dialog or should it change just after the invitation has been accepted?
Or should this be only a problem that concerns the icon showed in the dialog but not the role value stored in the calendar (Lightning shows the REQ-PARTICIPANT icon but stores the original role value, even if wrong)?
(Reporter)

Updated

8 years ago
Duplicate of this bug: 538955
(Reporter)

Updated

8 years ago
Duplicate of this bug: 536276
(Assignee)

Comment 6

8 years ago
Created attachment 431125 [details] [diff] [review]
Fallback to REQ-PARTICIPANT if ROLE is undefined
Assignee: nobody → simon.at.orcl
(Assignee)

Updated

8 years ago
Attachment #431125 - Flags: review?(philipp)
Status: NEW → ASSIGNED
OS: Windows 7 → All
Hardware: x86 → All
Created attachment 431421 [details] [diff] [review]
Fallback using CSS instead

I'd prefer we fix this on the CSS side to allow potential userChrome.css to differ between a not specified role and the REQ-PARTICIPANT role.

Please test this in a real environment, I only did a basic smoketest. Feel free to adapt if I did something wrong.
Attachment #431125 - Attachment is obsolete: true
Attachment #431421 - Flags: review?(simon.at.orcl)
Attachment #431125 - Flags: review?(philipp)
(Assignee)

Comment 8

8 years ago
Created attachment 431655 [details] [diff] [review]
[checked in] Fixed role attribute not set properly and add loading of the needed calendar-ui-utils script
Attachment #431421 - Attachment is obsolete: true
Attachment #431421 - Flags: review?(simon.at.orcl)
(Assignee)

Updated

8 years ago
Attachment #431655 - Flags: review?(philipp)
Comment on attachment 431655 [details] [diff] [review]
[checked in] Fixed role attribute not set properly and add loading of the needed calendar-ui-utils script

r=philipp
Attachment #431655 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/27da2a32b708>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: blocking-calendar1.0?
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2

Comment 11

8 years ago
Does the patch need the pinstripe part for the file calendar-event-dialog.css?

I've tried the latest nightly, and I've seen that the icon related to the last attendee (see ics calendar attached) doesn't change when clicking on it, even changing the attendee with a new one that has a  "Needs action" status (but again without a role) e.g.

ATTENDEE;RSVP=TRUE;CN=Daniel XXXXX;PARTSTAT=NEEDS-ACTION:mailto:44444@XXXX.org

Is it the right behavior?
Duh, of course it needs a pinstripe change :-( I really need to get bug 533096 fixed soon, this has happened to me more than once lately! I'll also fix the other bug while I'm at it, thanks for noticing!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #431655 - Attachment description: Fixed role attribute not set properly and add loading of the needed calendar-ui-utils script → [checked in] Fixed role attribute not set properly and add loading of the needed calendar-ui-utils script
Created attachment 432906 [details] [diff] [review]
Regression Fix - v1
Attachment #432906 - Flags: review?
Attachment #432906 - Flags: review? → review?(simon.at.orcl)

Updated

8 years ago
Duplicate of this bug: 539653
(Assignee)

Updated

8 years ago
Attachment #432906 - Flags: review?(simon.at.orcl) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/a6d254943619>

-> FIXED
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 554038
Duplicate of this bug: 570456
You need to log in before you can comment on or make changes to this bug.