crash in GTK gfx code if XGetImage fails

VERIFIED DUPLICATE of bug 52275

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 52275
17 years ago
17 years ago

People

(Reporter: Decklin Foster, Assigned: tor)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
We allocate an XImage here:

http://lxr.mozilla.org/seamonkey/source/gfx/src/gtk/nsImageGTK.cpp#717

and then use it without checking to see if it was actually allocated. This is
causing crashes for me; I can only reproduce them using my own skin though (I
can add the URL for that if you think I'm at fault). I'm attaching a patch which
just checks the ximage with an assertion after we call XGetImage. Assigning to
tor based on cvs blame.
(Reporter)

Comment 1

17 years ago
Created attachment 14881 [details] [diff] [review]
add assertion after XGetImage

Comment 2

17 years ago
bug 52980 crash in libgfx_gtk.so
(Assignee)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 52275 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.