random orange: test_compatmode.html timed out

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

In a build testing revision http://hg.mozilla.org/mozilla-central/rev/62fb8fbc417c there was a random orange:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258648868.1258650225.10334.gz
Linux mozilla-central debug test mochitests-5/5 on 2009/11/19 08:41:08
s: moz2-linux-slave23
317 ERROR TEST-UNEXPECTED-FAIL | /tests/parser/htmlparser/tests/mochitest/test_compatmode.html | Test timed out.

This may be related to the changes in http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2009-11-19+07%3A00%3A00&enddate=2009-11-19+07%3A30%3A00
Whiteboard: [orange]
Doesn't seem to have happened again (yet), though.
I checked all the subsequent test runs, and this problem hasn't shown up again.

I can't explain how it showed up once, but I guess it's best if I don't touch the test during the 3.6 freeze, since the problem is staying away.

Once bug 529544 has a proper fix, test_compatmode.html can be reverted to running with the HTML5 parser, too.
Comment hidden (Legacy TBPL/Treeherder Robot)
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.