Get error message in error console if I click on a link where I have <base target="_blank"> in the file

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Steve Greenberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

<html>
  <head>
    <base target="_blank">
    <title>Discovering there is a problem with &lt;base target="_blank"></title>
  </head>
  <body>
    <h1>Discovering there is a problem with &lt;base target="_blank"></h1>

    <p>Problem found in Firefox 3.5.5 on Windows-XP.  <q>Mozilla/5.0
    (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102
    Firefox/3.5.5</q>

    <ol>
      <li>Turn on the error console with CTRL-SHFT-J</li>
      <li>Click on this <a href="#">Problematic Link</a>
      <li>See the following two error messages:
        <blockquote>
Error: Permission denied for &lt;file://> to call method UnnamedClass.toString on &lt;>.
<p>Error: uncaught exception: unknown (can't convert to string)
	</blockquote></li>
      <li>Clear the error console</li>
      <li>Comment out or remove the<kbd> &lt;base target="_blank">
        </kbd>statement in this file.</li>
      <li>Reload this file</li>
      <li>Click on this <a href="#">Problematic Link</a>
      <li>Notice that there is no error message</li>
    <ol>

  </body>
</html>


Reproducible: Always

Steps to Reproduce:
1A. Put the above HTML in a file and browse to the file.
1. Turn on the error console with CTRL-SHFT-J
2. Click on this Problematic Link
3. See the following two error messages:

    Error: Permission denied for <file://> to call method UnnamedClass.toString on <>.

    Error: uncaught exception: unknown (can't convert to string) 

4. Clear the error console
5. Comment out or remove the <base target="_blank"> statement in this file.
6. Reload this file
7. Click on this Problematic Link
8. Notice that there is no error message

I am using the option to open a new tab when the target is _blank

Actual Results:  
Error: Permission denied for <file://> to call method UnnamedClass.toString on <>.

Error: uncaught exception: unknown (can't convert to string) 



Expected Results:  
There should be no error messages.
Works for me. Could you test again with Firefox 4 and reopen if this still is a problem for you?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → DOM: Core & HTML
Product: Firefox → Core
QA Contact: general → general
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

8 years ago
I was using Firefox 3.6.3 just now and the bug was still there.

Apparently my automatic updates have been frozen since an interruption in downloading the update for 3.6.4.

I just manually updated to 3.6.13 and find that the bug is gone.

I am not into testing Firefox beta releases, so I'll defer on testing this in Firefox 4.  Doesn't seem to be necessary anyway.
Resolution: WORKSFORME → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.