Last Comment Bug 530063 - Interfaces changed without changing iid
: Interfaces changed without changing iid
Status: VERIFIED FIXED
[tb3ride-along][fixed RC1 build 3]
: fixed-seamonkey2.0.1
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: Trunk
: All All
: -- critical (vote)
: Thunderbird 3
Assigned To: palo misik
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-20 06:02 PST by palo misik
Modified: 2010-01-08 04:33 PST (History)
3 users (show)
standard8: blocking‑thunderbird3-
standard8: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
.1-fixed


Attachments
proposed patch (2.33 KB, patch)
2009-11-20 06:22 PST, palo misik
standard8: review+
mozilla: superreview+
standard8: approval‑thunderbird3+
Details | Diff | Splinter Review

Description palo misik 2009-11-20 06:02:25 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729) XPCOMViewer/0.9a
Build Identifier: 

I again find interface iid issues

here they are conflicts between tb2 and tb3:
nsIMsgCustomColumnHandler needs new iid due to changes in parent interface nsITreeView
nsIStatusBarBiffManager needs new iid due to changes in parent interface nsIFolderListener

conflicts between tb3b4 and tb3rc1build2
Method nsIAddrDatabase.getCardsFromAttribute() has been added.


Reproducible: Always
Comment 1 Ludovic Hirlimann [:Usul] 2009-11-20 06:06:42 PST
Palo can you provide a patch ?
Comment 2 palo misik 2009-11-20 06:22:57 PST
Created attachment 413601 [details] [diff] [review]
proposed patch
Comment 3 rsx11m 2009-11-20 07:21:10 PST
You are changing mailnews code, thus you'll need to request superreview too.
Comment 4 Mark Banner (:standard8) 2009-11-20 10:45:19 PST
Not blocking on this, but as we unfortunately are doing a build 3 we'll take it as ride along.
Comment 5 Mark Banner (:standard8) 2009-11-20 14:00:21 PST
Fix checked in:

comm-central: http://hg.mozilla.org/comm-central/rev/0c4c033ebed0
comm-1.9.1: http://hg.mozilla.org/releases/comm-1.9.1/rev/63a0ae424d41
comm-1.9.1 (relbranch): http://hg.mozilla.org/releases/comm-1.9.1/rev/9110cabbd340

Sorry, I forgot to change the username when checking the patch in.
Comment 6 Ludovic Hirlimann [:Usul] 2009-11-22 22:06:19 PST
Verified by code change.

Note You need to log in before you can comment on or make changes to this bug.