Closed Bug 530087 Opened 11 years ago Closed 11 years ago

improve xptcinvoke for linux on arm

Categories

(Core :: XPCOM, defect)

ARM
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 532198
Tracking Status
fennec 1.0- ---

People

(Reporter: blassey, Assigned: jbramley)

Details

Attachments

(1 file)

We got a pretty good perf boost in bug 529348 for windows ce and windows mobile, I'd like to see if a similar approach would help maemo.
tracking-fennec: --- → ?
tracking-fennec: ? → 1.0-
Flags: wanted-fennec1.0+
Attached patch patchSplinter Review
with this patch, I see a 1.68x improvement according to the speed test in TextXPTCInvoke

without patch:
 direct took 9.05 seconds
 invoke took 111.08 seconds
 So, invoke overhead was ~ 102.03 seconds (~ 92%)

with patch:
 direct took 9.12 seconds
 invoke took 69.88 seconds
 So, invoke overhead was ~ 60.76 seconds (~ 87%)
Assignee: nobody → bugmail
Attachment #413887 - Flags: review?(vladimir)
Attachment #413887 - Flags: approval1.9.2?
Ts impact:

without: 10613, 11228, 10777, 11224 => 10960.5 average 
with: 10130, 10252, 11130, 10867 => 10602.25 average

so, by my testing its a 358.25ms win
a=beltzner to land this on trunk once it passes review; find me again (I'll be around!) for a192 if that works out cleanly.
FWIW, I've done a bit of browsing on a WinCE trunk nightly with this change, and it seems to work fine.
Attachment #413887 - Flags: review?(vladimir)
Attachment #413887 - Flags: review+
Attachment #413887 - Flags: approval1.9.2?
Attachment #413887 - Flags: approval1.9.2+
pushed http://hg.mozilla.org/mozilla-central/rev/0573fb2293c0
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
backed out
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Bug 532198 includes a patch that does a small bit of what the patch in this bug does.
Comment on attachment 413887 [details] [diff] [review]
patch

Unapproving due to bounce
Attachment #413887 - Flags: approval1.9.2+
Assignee: bugmail → Jacob.Bramley
Jacob - any thoughts on when you will be working on this bug? I'm curious as to when we might see it for a fennec release.
Yep, I'm looking at it now but it keeps being interrupted by unrelated things, and it's being slow due to native ARM build times. (That isn't really a problem for Trace Monkey builds, but it is for XPCOM.)

I have a couple of patches that just need testing, though I don't know why you saw that failure before and I suspect whatever caused it will be in my patch too.
can we close this/dup it to 532198?
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 532198
You need to log in before you can comment on or make changes to this bug.