Page scrolling slows down and becomes jittery when page with embedded flash is zoomed/magnified (in or out)

RESOLVED DUPLICATE of bug 480806

Status

()

--
minor
RESOLVED DUPLICATE of bug 480806
9 years ago
9 years ago

People

(Reporter: endymon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

I've been having this problem for a while, but I finally figured out what was causing it. Apparently if a webpage with certain page elements (seems to be flash and some others I haven't identified) is magnified either +/- the ability to scroll the page becomes severely hampered.
Example Pages
http://www.wow.com
http://www.worldofwarcraft.com/cataclysm/
(yeah they are both wow related sites, didn't want to bother finding other examples at this time)
The scrolling issue persists until the offending element/object leaves the current viewable area. So, shrinking the window can hide the symptoms.
This does not seem to occur universally. Example www.youtube.com works properly.
CPU resources are used as a much much higher rate than normal when the scrolling issue is manifest.
In this particular example with page zoom at default scrolling one core uses about 65% capacity. With zoom + 1 two cores are used at 75% capacity each.

Reproducible: Always

Steps to Reproduce:
NOTE: Any website the this bug occurs on, will occur every time, similarly, any website in which this bug does not occur, will never occur.
1. Visit website with embedded objects (flash or unnamed other) (example www.wow.com)
2. Scroll page in any direction (up/down, left/right doesn't matter)
3. Adjust zoom level (+ or -)
4. Contrast scroll responsiveness with step 2.
Actual Results:  
Page scrolling is severely impaired.

Expected Results:  
Page scrolling is not adversely effected.

CPU power of system does not seem to effect this. This occurred on both of my system configs over the past few months. The fact that it eats cpu cycles and yet still suffers massive performance loss is not a good sign. If this just ate more CPU cores but didn't effect performance hey, no big issue, but if ever a program eats more resources for less performance that worries me.

Comment 1

9 years ago
Same issue as Bug 480806?
(Reporter)

Comment 2

9 years ago
I remember reading Bug 480806 and although the description is similar it didn't seem like the same issue based on the comments (though perhaps those comments were just expanding the issue like a cancer to encompass many many variations)

However I will say this, after testing on www.winsupersite.com (as mentioned in the comments of bug 480806) I see my issue on that page. Specifically bug 480806 mentions that www.winsupersite.com scrolls slow regardless of zoom, and gets worse when zoomed. For me, it scrolls fine without zoom but does indeed scroll badly once zoom is activated. 

On another note the page http://scienceblogs.com/pharyngula/ listed in comment #6 does not exhibit any slowdown in any zoom level.

Therefore, it is your call whether it is the same issue or if 480806 is actually 2 separate issues.

Comment 3

9 years ago
Based on the fact that your began experiencing this 'some time ago' I think that the dup to Bug 480806 is the right call.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 480806
You need to log in before you can comment on or make changes to this bug.