Closed Bug 530279 Opened 12 years ago Closed 12 years ago

[HTML5] Proboards crashes [@ nsHtml5PendingNotification::nsHtml5PendingNotification(nsIContent*)]

Categories

(Core :: DOM: HTML Parser, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 525229

People

(Reporter: danialhorton, Unassigned)

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.3a1pre) Gecko/20091120 Minefield/3.7a1pre GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.3a1pre) Gecko/20091120 Minefield/3.7a1pre GTB6 (.NET CLR 3.5.30729)

When browsing a proboards topic or viewing the recent posts list, firefox crashes with a XUL error, I was able to get the crash reporter to catch the crash atleast once and it indicated it is html5 related.

http://crash-stats.mozilla.com/report/index/bp-760360cd-c928-42e4-abb7-a96462091121

Reproducible: Always

Steps to Reproduce:
With HTML5 enabled

1. Go to either http://thecove.proboards.com/index.cgi or http://support.proboards.com/index.cgi
2. navigate some topics or the recent topics/posts list.
3. 
Actual Results:  
Firefox crashes either with a exception in XUL, or the crash logger indicates a crash in HTML5

Expected Results:  
Firefox does not crash.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 525229
Signature	nsHtml5PendingNotification::nsHtml5PendingNotification(nsIContent*)
UUID	760360cd-c928-42e4-abb7-a96462091121
Time 	2009-11-21 01:49:20.251556
Uptime	34
Last Crash	737434 seconds before submission
Product	Firefox
Version	3.7a1pre
Build ID	20091120042913
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 26 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x0
User Comments	
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature 	Source
0 	xul.dll 	nsHtml5PendingNotification::nsHtml5PendingNotification(nsIContent*) 	parser/html/nsHtml5PendingNotification.h:51
1 	xul.dll 	nsTArrayElementTraits<nsHtml5PendingNotification>::Construct<nsIContent*>(nsHtml5PendingNotification*,nsIContent* const&) 	obj-firefox/dist/include/nsTArray.h:193
2 	xul.dll 	nsTArray<nsHtml5PendingNotification>::AssignRange<nsIContent*>(unsigned int,unsigned int,nsIContent* const*) 	obj-firefox/dist/include/nsTArray.h:891
3 	xul.dll 	nsTArray<nsHtml5PendingNotification>::AppendElements<nsIContent*>(nsIContent* const*,unsigned int) 	obj-firefox/dist/include/nsTArray.h:618
4 	xul.dll 	nsHtml5TreeOpExecutor::PostPendingAppendNotification(nsIContent*,nsIContent*) 	parser/html/nsHtml5TreeOpExecutor.h:263
5 	xul.dll 	nsHtml5TreeOperation::Perform(nsHtml5TreeOpExecutor*) 	parser/html/nsHtml5TreeOperation.cpp:104
6 	xul.dll 	nsHtml5TreeOpExecutor::Flush() 	parser/html/nsHtml5TreeOpExecutor.cpp:312
7 	xul.dll 	nsHtml5ExecutorFlusher::Run() 	parser/html/nsHtml5StreamParser.cpp:110
8 	xul.dll 	nsThread::ProcessNextEvent(int,int*) 	xpcom/threads/nsThread.cpp:527
9 	xul.dll 	nsBaseAppShell::Run() 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
10 	nspr4.dll 	PR_GetEnv 	
11 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:120
12 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
13 	kernel32.dll 	kernel32.dll@0x13676 	
14 	ntdll.dll 	ntdll.dll@0x39d71 	
15 	ntdll.dll 	ntdll.dll@0x39d44

Another dupe of Bug 525229?
Status: RESOLVED → UNCONFIRMED
Component: General → HTML: Parser
Keywords: crash
Product: Firefox → Core
QA Contact: general → parser
Resolution: DUPLICATE → ---
Summary: Proboards crashes with HTML5 enabled. → [HTML5] Proboards crashes [@ nsHtml5PendingNotification::nsHtml5PendingNotification(nsIContent*)]
Version: unspecified → Trunk
Damn Midairing ...
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 525229
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsHtml5PendingNotification::nsHtml5PendingNotification(nsIContent*)]
You need to log in before you can comment on or make changes to this bug.