remove ctrl-q keyboard shortcut

RESOLVED WONTFIX

Status

()

--
minor
RESOLVED WONTFIX
9 years ago
6 years ago

People

(Reporter: trx.lists, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX?)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091109 Gentoo Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091109 Gentoo Firefox/3.5.5

ctrl-q keyboard shortcut is way too close to ctrl-w (close tab) shortcut.



Reproducible: Always

Steps to Reproduce:
1. open a lot of tabs, say google search results
2. start reading tab by tab, closing every read one
3. eventualy, you'll hit ctrl-q instead of ctrl-w
Actual Results:  
all your needed tabs are gone

Expected Results:  
get some error or no action at all if I miss my ctrl-w :)

Updated

9 years ago
Whiteboard: WONTFIX?

Comment 1

9 years ago
Or, you could just re-enable "Warn me when closing multiple tabs" in the options.
(Reporter)

Comment 2

9 years ago
that's one of workarounds.

maybe even better would be to add about:config option for setting/disabling all keyboard shortcuts.

Updated

8 years ago
Component: General → Keyboard Navigation
QA Contact: general → keyboard.navigation
Version: unspecified → Trunk
(Reporter)

Comment 3

8 years ago
adding about:config options for setting and/or disabling for all keyboard shortcuts would not ruin average users' experiance, and on the other hand, that would let people interested in fine-tunning to customize what they need.

Comment 4

8 years ago
the prompt that asks if you want to quit is the default behavior
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

7 years ago
Duplicate of this bug: 677702

Comment 6

7 years ago
The "Warn me when closing multiple tabs" option does not work for me. The CTRL+Q shortcut still quits firefox without asking.

If the "Warn me when closing multiple tabs" option was intended to work even when using the CTRL+Q shortcut, then it seems the option is at least partly broken.

Comment 7

7 years ago
(In reply to Jelle Geerts from comment #6)
> If the "Warn me when closing multiple tabs" option was intended to work even
> when using the CTRL+Q shortcut, then it seems the option is at least partly
> broken.

Yes, sounds like bug #419009 - which currently has 43 votes.

Comment 8

6 years ago
(In reply to Jelle Geerts from comment #6)
> The "Warn me when closing multiple tabs" option does not work for me. The
> CTRL+Q shortcut still quits firefox without asking.
> 
> If the "Warn me when closing multiple tabs" option was intended to work even
> when using the CTRL+Q shortcut, then it seems the option is at least partly
> broken.

I think it's only meant to work on CTRL+Q if browser.showQuitWarning is set to true.
You need to log in before you can comment on or make changes to this bug.