If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<audio> tag downloads file multiple times

RESOLVED DUPLICATE of bug 502894

Status

()

Core
Audio/Video
P2
normal
RESOLVED DUPLICATE of bug 502894
8 years ago
8 years ago

People

(Reporter: Craig, Unassigned)

Tracking

1.9.1 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091114 Gentoo Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091114 Gentoo Firefox/3.5.5

When I use the <audio> tag to make firefox play an ogg, it gets downloaded multiple times:

192.168.0.1 - - [22/Nov/2009:18:38:45 +0100] "GET /ogg.ogg HTTP/1.1" 206 5531945 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091114 Gentoo Firefox/3.5.5"
192.168.0.1 - - [22/Nov/2009:18:38:45 +0100] "GET /ogg.ogg HTTP/1.1" 206 4425 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091114 Gentoo Firefox/3.5.5"
192.168.0.1 - - [22/Nov/2009:18:38:45 +0100] "GET /ogg.ogg HTTP/1.1" 206 5538121 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091114 Gentoo Firefox/3.5.5"

The downloaded file "ogg.ogg" has 5603657 bytes.

I used wireshark to have a look at the headers (I was wondering, why there are three 206s!)

The first request does:
Range: bytes=0-

The second:
Range: bytes=5599232-

The third:
Range: bytes=32768-

That's the only difference. It's not nice to have about two times the traffic.

Reproducible: Always

Steps to Reproduce:
1. tail -f access_log
2. sniff the traffic
3. download an ogg file
4. see three requests in the logs.


Expected Results:  
One request.
(Reporter)

Updated

8 years ago
Priority: -- → P2
Version: unspecified → 3.5 Branch
(Reporter)

Comment 1

8 years ago
Upon further research I noticed, this is related to the webservers reaction to the byte-range request: if the server just answers with a 200 instead of 206 code, there will only be one request, but then the seekbar does not behave normally. It will play the track, but it's always at the right side and displays the current position. You can skip backwards, but not forward; this changes after you downloaded the ogg for the first time, if you play it a second time, it's ok.
Related to Bug 502894 ?
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: 3.5 Branch → 1.9.1 Branch
(In reply to comment #2)
> Related to Bug 502894 ?

Yes. See bug 502894 comment 1 for a description of what's going on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 502894
You need to log in before you can comment on or make changes to this bug.