Closed Bug 530524 Opened 12 years ago Closed 9 years ago

idmmzcc.dll Crash [@ MultiByteToWideChar ]

Categories

(Toolkit :: Blocklist Policy Requests, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 578443

People

(Reporter: cbook, Assigned: charles)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

seems to a appear in a wide number of releases with most reports on the lastest big releases.

distribution of all versions where the MultiByteToWideChar crash was found on 20091119-crashdata.csv
  47 Firefox 3.5.5
  25 Firefox 3.0.15
  17 Firefox 3.6b3
  15 Firefox 3.0.5
  14 Firefox 3.0b2
  12 Firefox 3.5.2
  12 Firefox 3.0b5
< long tail of releases snipped >

No URLs for most of these crash reports, possibly confirming that this is nearly all a problem in start up code.

domains of sites
 173 //
  17 \N//
   2 http://www.facebook.com
   1 http://www.twhg.com.tw
   1 http://www.tagged.com
   1 http://www.sogi.com.tw
   1 http://www.mozilla-europe.org
   1 http://www.into.uk.com
   1 http://www.divxden.com
   1 http://www.cellularfactory.com
   1 http://wg105.odnoklassniki.ru
   1 http://forum.gamer.com.tw
   1 http://en-us.www.mozilla.com
Summary: Crash [@MultiByteToWideChar ] → Crash [@ MultiByteToWideChar ]
Signature	MultiByteToWideChar
UUID	fe80002c-dce9-4769-a96e-445b02091123
Time 	2009-11-23 07:20:31.976951
Uptime	0
Last Crash	2288 seconds before submission
Product	Firefox
Version	3.6b3
Build ID	20091115182845
Branch	1.9.2
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	AuthenticAMD family 15 model 107 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x35
User Comments	
Processor Notes 	WARNING: Json file missing Add-ons
Related Bugs

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	kernel32.dll 	MultiByteToWideChar 	
1 	nspr4.dll 	pr_LoadLibraryByPathname 	nsprpub/pr/src/linking/prlink.c:698
2 	nspr4.dll 	PR_LoadLibraryWithFlags 	nsprpub/pr/src/linking/prlink.c:455
3 	idmmzcc.dll 	idmmzcc.dll@0xca81 	
4 	idmmzcc.dll 	idmmzcc.dll@0xd3a3 	
5 	idmmzcc.dll 	idmmzcc.dll@0xd507 	
6 	xul.dll 	nsFactoryEntry::GetFactory 	xpcom/components/nsComponentManager.cpp:3706
7 	xul.dll 	nsComponentManagerImpl::CreateInstanceByContractID 	xpcom/components/nsComponentManager.cpp:1680
8 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:2252
9 	xul.dll 	nsCOMPtr_base::assign_from_gs_contractid_with_error 	obj-firefox/xpcom/build/nsCOMPtr.cpp:141
10 	xul.dll 	nsCOMPtr<nsISupports>::nsCOMPtr<nsISupports> 	obj-firefox/dist/include/nsCOMPtr.h:948
11 	xul.dll 	NS_CreateServicesFromCategory 	xpcom/components/nsCategoryManager.cpp:886
12 	xul.dll 	NS_InitXPCOM3_P 	xpcom/build/nsXPComInit.cpp:711
13 	xul.dll 	ScopedXPCOMStartup::Initialize 	toolkit/xre/nsAppRunner.cpp:1090
14 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3290
15 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:120
16 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
17 	kernel32.dll 	BaseProcessStart 	

idmmzcc.dll 	4.0.0.1
Summary: Crash [@ MultiByteToWideChar ] → idmmzcc.dll Crash [@ MultiByteToWideChar ]
idmmzcc.dll is from Internet Download Manager http://www.checkfilename.com/view-details/Internet-Download-Manager/
bug 382356 ... ??
Assignee: nobody → charles
Component: General → Blocklisting
Product: Core → addons.mozilla.org
QA Contact: general → blocklisting
Version: 1.9.2 Branch → unspecified
I just had a user with a related crash (http://crash-stats.mozilla.com/report/index/5a4194be-0573-499d-b249-eb4722101118), and there was a malware extension installed called Adware.DoubleD.  MalwareBytes should remove it.
logan: what was the extension id? (this would help w/ blocklisting or at least for others to recognize it from crash-stats)
{0BA0192D-94A5-45e3-B2B8-3EC5A1A0B5EC} was the extension ID.  Version 1.5.5.900.  It seems that it is called Media Access Startup within Firefox (Googled it).
Flags: in-testsuite+
Flags: in-litmus+
Crash Signature: [@ MultiByteToWideChar ]
Attached file idm intrigation
please enable it
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578443
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.