Closed Bug 530786 Opened 11 years ago Closed 6 years ago

skydrive.live.com - XML Parsing Error caused by sniffing for "Firefox" instead of "Gecko"

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: chokito, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.23) Gecko/20090825 SeaMonkey/1.1.18
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.23) Gecko/20090825 SeaMonkey/1.1.18

XML Parsing Error: not well-formed
Location: http://skydrive.live.com/
Line Number 39, Column 184:

<div id="m_wh"><script type="text/javascript">/* Copyright (C) 2009 Microsoft Corporation */function $c_TreatTile(a,e){a.style.display=e;var d=a.width,c=a.height,b=19;if(d>=c||c<b)a.height=b;if(d<c||d<b)a.width=b}</script>


Reproducible: Always

Steps to Reproduce:
1. Visit http://skydrive.live.com/
2.
3.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6pre) Gecko/20091124 SeaMonkey/2.0.1pre - Build ID: 20091124000514

I confirm the problem. I believe that the problem is not due to an error in SeaMonkey but to a malformed web page.

Reporter: please try to contact the site webmaster after reading http://www.mozilla.org/projects/tech-evangelism/site/procedures.html and any relevant pages linked from there; then report here to say if you were successful.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
OS: Windows XP → All
Product: SeaMonkey → Tech Evangelism
QA Contact: general → english-us
Hardware: x86 → All
Summary: XML Parsing Error → skydrive.live.com - XML Parsing Error
(In reply to comment #1)
> 
> I confirm the problem. I believe that the problem is not due to an error in
> SeaMonkey but to a malformed web page.
> 

The problem exists not on Firefox 3.5.5.
(In reply to comment #2)
> The problem exists not on Firefox 3.5.5.

Hm. Then it could be due to the page using some "too recent" version of the (xml, xhtml or javascript) language; or it could be a real bug in the Javascript parser, but maybe fixed in a later version of Gecko (I don't know Javascript well enough to say if it is correctly used here, and by which version of the ECMAscript standard).

What is the long string after "Build Identifier" at the bottom of the page displayed when you write "about:" (without the quotes, but with the colon) in Firefox 3.5.5's URL bar? (Please use copy & paste. The equivalent for your version of SeaMonkey appears in comment #0, and for mine, before the dash in comment #1). I expect it to have, at the end of the parenthesis, some later version than rv:1.9.1.6pre, but I could be wrong.
Answer: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Well, I'm out of my depth here. I'm bringing in Javascript specialists so they may ask the right questions and possibly move the bug to a different Product/Component. I'll summarize the problem for their benefit:

The page http://skydrive.live.com/ is displayed correctly by Firefox 3.5.5 on Windows (with Gecko 1.9.1.5, see comment #4) but it gets "XML parsing error" in the middle of a <script> in both SeaMonkey 1.1.18 on Windows (with Gecko 1.8.1.23, see comment #0) and SeaMonkey 2.0.1pre on Linux (with Gecko 1.9.1.6pre, see comment #1).

I'm starting to wonder whether this is a Tech Evangelism bug, a Javascript Engine bug... or something else.
They're probably sniffing -- server-side -- for "Firefox" in the UA string and feeding other browsers broken XML. We've seen several instances of this in TE bugs lately. Try spoofing as Firefox 3.5 (or simply adding "not Firefox 3.5" to a Seamonkey UA string) and see if that fixes it.

On Camino, as long as "Firefox/" is present followed by a version number (e.g., 2.0, 3.0, 3.5), the site works great. If I remove that part of the UA string, it immediately breaks.

cl
Blocks: geckoisgecko
Summary: skydrive.live.com - XML Parsing Error → skydrive.live.com - XML Parsing Error caused by sniffing for "Firefox" instead of "Gecko"
In reply to comment #6
On SeaMonkey 2, setting the UA to

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6pre) Gecko/20091125 SeaMonkey/2.0.1pre, a sibling of Firefox/3.5

by means of the "UserAgent Switcher" extension, makes the problem disappear. Chris, I knew about this kind of "problem sites" but somehow I'd forgot about them. Brilliant!

Urs, you can either use UserAgent Switcher (if it's installed) to set your UA string to something mimicking Firefox, or try the following (in SeaMonkey 1.1.18):
1. Type "about:config" (without the quotes) into the URL bar, then hit Enter
2. Type "usera" (without the quotes) in the Filter box
3. If there exists a preference named "general.useragent.extra.seamonkey", then:
    3.1. Click right, then New => String
    3.2. New name: "general.useragent.extra.firefox" (without quotes)
    3.3. New value: "NOT Firefox/3.5.5" (without quotes)
3a. Otherwise:
    3a.1. Copy your SeaMonkey 1.1.18 useragent (e.g. from comment #0) to the clipboard
    3a.2. If you see "general.useragent.override", click right on it, then "Modify". If you don't see it, create it in a way similar to 3.1 and 3.2 above
    3a.3. New value: Paste (Ctrl+V) the clipboard contents, then add " NOT Firefox/3.5.5" (without the quotes) at the end
4. Try browsing your problem site and note whether it works or not.
5. In about:config, click right on the preference created or modified at step 3 or 3a above, then Reset. (This sets your user-agent string back to normal.)

I expect that that it will work at step 4 and go back to "not working" after step 5, which would mean that the site is doing "broken browser sniffing".
Chris and Tony, thanks for the tip.

I have followed the instructions from you. It's the additional entry "Firefox/3.5
" that's fix the problem. My UA now modified to: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.23) Gecko/20090825 SeaMonkey/1.1.18 NOT Firefox/3.5

Greetings from Switzerland
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
We need to leave this open, since Microsoft clearly hasn't fixed it.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to comment #6)
> They're probably sniffing -- server-side -- for "Firefox" in the UA string and
> feeding other browsers broken XML. We've seen several instances of this in TE
> bugs lately.

It's also a common Microsoft bug; we've seen it before at live.com subdomains and other Microsoft properties.
Status: REOPENED → NEW
Duplicate of this bug: 521798
Now redirected to https://onedrive.live.com/about/en-us/
No issue. Site has changed.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 11 years ago6 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.