Search Engine ordering gets jumbled up when switching from Fx 3.5.5 to Fx 3.6 Beta 1

RESOLVED INVALID

Status

()

Firefox
Search
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: Stephen Judge, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1

I have about 20 search engines installed and I have them organised in a paricular order. When I switch over to Fx 3.6. Beta 1 from Fx 3.5.5 the order of the search engines is all mixed up and some of them even disappear.  If I change the order of them while in Fx 3.6 Beta 1, this is not saved when switching back to Fx 3.5.5 and they are mixed up as before.  I have disabled all extensions to make sure they are not causing this, and it still occurs.  I have only tested this on Windows XP.

Reproducible: Always

Steps to Reproduce:
1. Install a few search engines
2. Reorganise them to a particular order
3. Install Fx 3.6 Beta 1 and start up
4. Note that the order of the search engines has changed
5. Close Fx 3.6 Beta 1 and return to Fx 3.5.5 and the search engine ordering remains mixed up.
6. This will always happen no matter how many times you reorganise them.
Actual Results:  
Search engine order gets changed.

Expected Results:  
Should retain the order the search engines are set to across all versions of Firefox.
If you don't mind revealing your list of search engines, could you attach your search.sqlite and search.json files from your profile directory (http://support.mozilla.com/en-US/kb/Profiles) to this bug? They don't contain any history of your searches, just the search engine definitions themselves and associated metadata like order, updateURL, etc. It would help pinpoint the problem, since I don't think this is commonly reproducable (I haven't heard of any other cases of this happening).
(Reporter)

Comment 2

9 years ago
Created attachment 414298 [details]
My search.json file for testing
(Reporter)

Comment 3

9 years ago
Created attachment 414299 [details]
My search.sqlite file for testing
Attachment #414298 - Attachment mime type: application/octet-stream → text/plain
Your search.sqlite does have some duplicate "order" entries which shouldn't be possible. Are you able to reproduce this consistently using the steps in comment 0 with a new profile? If so, how are you installing the engines?

Are the builds you're testing from different locales (e.g. en-GB for 3.5.5 and en-US for 3.6 beta 1)? I noticed that you had entries for both en-GB and en-US plugins in your search.sqlite.

Comment 5

7 years ago
I also have this problem. I used Add to search bar addon to add some of the entries (https://addons.mozilla.org/en-US/firefox/addon/add-to-search-bar/). Maybe it is the offender.

Updated

7 years ago
Version: unspecified → 3.6 Branch
boomman, which steps are necessary to reproduce this behavior? Is the installation of that add-on enough? Does it also happen with the latest beta of Firefox 4?
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Stephen, do you have any explanation why you have closed this bug as invalid? Thanks.
You need to log in before you can comment on or make changes to this bug.