Closed Bug 530801 Opened 11 years ago Closed 11 years ago

Saving website, complete, doesn't save images defined in CSS

Categories

(Firefox :: General, defect)

3.5 Branch
x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 115107

People

(Reporter: jon.ronnenberg, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; da; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; da; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

Whe saving a website, complete, the images defined in CSS is not stored locally. A good portion of images are now defined in CSS (in the wild) e.g. background images ect. meaning the impact is exponential.


https://bugzilla.mozilla.org/show_bug.cgi?id=318940#c3
rick2910@yahoo.com      2009-03-12 03:16:44 PDT

When saving a website to a local destination, Firefox doesn't save CSS images,
nor does it retain (for as far possible with relative paths) the file/folder
structure as present on the webserver. CSS images are vital for usability of a
saved website, file paths are important for developement tests.
Please implement the items mentioned above.

Reproducible: Always

Steps to Reproduce:
1. Ctrl+s
2. Choose Website, Complete
3. Open the saved htm file
Actual Results:  
Background images from CSS is not loaded.

Expected Results:  
Background images should be saved in the _files folder in sub folders relative to the CSS file(s).

One work around is to use Safari instead and save as webarchive.
Version: unspecified → 3.5 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 115107
You need to log in before you can comment on or make changes to this bug.